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1 General References

To provide a clear overview, this description does not include specific references to all parts
of the system and cannot possibly consider every assembly situation.

Any Problems related to hardware components, their installation and function should be

discussed and rectified in cooperation with the respective manufacturer
Should you require further IMAC L specific information, or should problems with a standard
installation arise, that this description does not cover adequately enough, please consult your
Siemens marine engineering partner to receive the desired information.

We would also like to state that the contents of this description does not exist due to prior

arrangement, consent or a legal position and does not alter any existing agreements.

All Siemens commitments ensue from the respective sales contract, which also contains the

complete and solely valid warranty control. These contractual warranty determinations will
not be expanded or limited by the execution of this system description.

In addition, no claims on the efficiency of the individual customer specific units can be
deflected by this description. The contractually agreed upon scope of delivery for each
specific contract is the decisive factor for the exact scope of supply for each unit.

Warning

During the operation of electrical appliances or units, it is inevitable that certain parts of
these units will contain high voltage.

When warnings are disregarded, grievous bodily harm or material damage can occur.

Only qualified personnel should operate or work in proximity with these appliances or
units.

These personnel must be familiar with all the warnings and maintenance measures
according to this system description or related descriptions e.g. SIMATIC-PLCs.

The flawless and safe operation of these appliances and units will be provided by
adequate transport, special storage, mounting and installation as well as thorough service
and maintenance.

Siemens keeps the right to change technical details without prior notification.

© Siemens AG 2009, All Rights reserved ¢ | 1S MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D4 / 97
IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



-

© 00 N O b~ W N

a4 A A A A a A A a A
© 0 N O b~ W N = O

21
22
23
24
25
26
27
28
29
30
31

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Introduction
2 Introduction

This manual describes the installation procedures required to setup and install ‘IMAC L’
Engineering PCs and Operator Stations (OSs).

If you should install the IMAC L Engineering System’ to a PC with an existing Windows
installation, you may skip the instructions for the basic installation of the operating system.
Nevertheless you have to carefully check all Windows settings and required drivers to
comply with the settings described in this document (be it default settings or custom
settings). This document cannot cover any whatsoever customized installation of any existing
PC.

The recommended installation procedure of the Windows Operating System is ‘from scratch’.
Real Operator Stations to be delivered to a customer necessarily require a installation ‘from

scratch’. All Prior Data stored on primary Partitions of the hard disk will be lost. Some Data

(e.g. in existing extended partitions) may be preserved during installation (but please do not
rely on this !).

In any case and independent of the type of Installation you choose please always create a
backup of any existing Data residing on your PC before proceeding !

3 Minimum Requirements for PC Hardware

Personal Computer with Pentium Il (or higher) or AMD Athlon XP Processor
Clock Frequency > 2,4 GHz

1 GB Memory

Graphics Card with >= 32 MB of Video Memory

CD-ROM or DVD-ROM Drive

Ethernet LAN Network Interface Controller (NIC) 100 Mbit with TCP/IP capability
Keyboard

Pointing Device (Mouse, Trackball)

BIOS must be capable of booting from CD-ROM

Windows XP Prof. (English), Service Pack 3 without any other Microsoft Hotfixes
NTFS File System

I

4 Required Software Components

The following table gives an overview of the software components to be installed for
Operator Stations and Engineering PCs :

Software Component OS Engineering | Comment

MS Windows XP Prof. en, SP3 Yes Yes English version of XP required,

not just an English language pack !
Only SP3, no other Hotfixes !

Adobe Acrobat Reader 8 or later | Optional Yes For viewing documentation
File packing tool (e.g. WinZip, | Optional Yes

WinRar, 7Zip)

Microsoft Excel 200x No Yes English Version required

not just an English language pack !

Simatic Step 7 V5.3 SP1 No Yes
(or higher), optionally current
HSP for recent hardware

AlphaVision Software >=V10.0 Yes Yes
Crystal Office WinLock Yes No
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1 The following table gives an overview of the software Licenses required for IMAC L :

Software Component Licenses Comment
required
MS Windows XP Prof. en, SP3 One per PC
WinZip or WinRar or 7Zip One per PC
Microsoft Excel One per PC
Simatic Step 7 One per PC
AlphaVision ‘Runtime’ for OS One per PC Free demo without license (30 min. limit)
AlphaVision ‘Engineering’ - Master license available for Siemens

Marine Engineering. For internal use only.
‘WiBu Key’ Key hardware holding the

[ (Oneper OS) | For use outside of Siemens Marine |
Engineering (e.g. selling to ship owner)

AbvSPU Signal Processing Unit One per PCU
Crystal Office WinLock One per OS Free 30 days demo
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5 Installation of PC (BIOS, Operating System)

5.1 PC BIOS Settings

Attention: Misadjusted settings in PC’s BIOS setup may cause a PC to fail or be unreliable.

Please change only those settings described explicitly here. All other settings
should be left in the ‘Manufacturer’s Default’ positions.

In cases of doubt and for detailed information on BIOS setup modification procedures of an
individual PC please consult the PC’s mainboard documentation.

Before installing the Operating System please check the BIOS setting of every PC to fulfill
the requirements of this section. After modifications check, if settings were successful.

To change the settings of a PC’s BIOS setup, please proceed as follows:

- To enter a PC’s BIOS setup program, you have to press a specific key during the
early part of the PC’s boot sequence. Usually the key to be pressed is shortly
displayed on the screen during boot (e.g. “F10 = BIOS Setup”). Common keys to
enter the BIOS setup program are ‘F10’ (e.g. HP/Compaq), ‘DEL’, or ‘F2’. With
modern, fast booting PCs it may sometimes be difficult to identify the correct time to
press this key. Repeated pressing of the key during the early part of booting helps to
find the correct time. If you can’t identify the correct key to press, please consult the
PC’s mainboard documentation.

- Navigate through the menus using the cursor keys. Modify the settings as required
by this manual.

- After Modification of settings is completed, you have to save these settings. Look for
a menu like ‘SAVE CHANGES & EXIT’ to do so. The PC will then reboot.

5.1.1 BIOS Settings for ‘Power ON after Power Loss’

On board of ship a power loss (black out) is a common situation. OSs usually will have an
uninterrupted power supply, but it has to be taken into account, that the UPS units will not
last forever. Therefore a power loss to an OS PC is a standard situation. For IMAC L
Operator Stations it is important, that the PCs will automatically revert to the same power
condition as they were before the power loss. Alternatively it is possible to have an

‘Always ON’ setting, but this will cause PCs to be switched on after a power loss, even if they
were switched off before the power loss.

Many BIOSes have a setting that determines the behavior of the PC after a power loss.
- In the BIOS menus look for ‘Startup’ options.

For HP/Compagq PCs the required setting is typically allocated in
“Advanced = Power-On Option”

The required settings item is
“After Power Loss”

The required setting of this item is
“Previous State”

- For other PC manufacturers you may need the mainboard documentation to identify
the required menu / setting.
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52 Installation of Windows XP

Please observe, that an original real ‘english’ version of Windows XP is required. Any
other language version of XP with an additional English language pack will not be suitable for
IMAC L!

Please install the required Windows XP operating system according to standard procedures:

o Install all optional PC hardware components as required.
0 Boot from Windows XP installation CD and complete the installation procedures
Use the following settings during XP installation:

- Format OS partition with ‘NTFS’ file system. The minimum partition size for
the Windows partition is 15 GB.

- Localization is ‘English US’ including English keyboard settings
- Select ‘Computer name’ according to use (e.g. 0S1,0S2, ENGINEERING)

- When prompted for an administrators password, take a written note of the
selected password and put it to your internal project documentation. The half-
life of your memory is smaller than you might imagine ;-)

- Set the Time Zone in XP to the home port or major operation base of the ship.

- Select an identical network workgroup name for all computers in the same
network (suggested for IMAC L: ‘WORKGROUP’)

o Boot from Windows XP installation CD and complete the installation procedures

5.3 Installation of Drivers for special Hardware Components

Windows XP will automatically detect most of the common ‘Plug & Play’ hardware
components and install appropriate Windows built-in drivers. Nevertheless there are
hardware components for which Windows has no built in drivers available. If this happens, it
will be necessary to install these drivers from disks supplied by the hardware manufacturer
instead. In most of these cases Windows will announce, that it has detected a new hardware
component. The dialogues following this announcement will guide you through the hardware
driver installation procedure. Please proceed according to the manual / installation guide
delivered with your hardware.

In case of doubt you can check for missing or faulty drivers :

- Clickon ‘Start > Settings = Control Panel'.
- Double-Click on ‘System’

- Click on tab ‘Hardware’

- Click on button ‘Device Manager’

The ‘Device Manager Window will show all detected devices in a tree style (similar to
Explorer file system display) :
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Look for devices with ‘Question Mark’, ‘Exclamation Mark’ or ‘Stop Sign’ Symbols.
Devices bearing these colored symbols will usually not work due to driver or resource
problems or missing drivers. Usually more information on a specific device is available :

- Select a device by clicking on it

- Click on ‘Action - Properties’.

Hint : Install all missing or faulty drivers according to manufacturers instructions. Installation
of drivers may include one or more boot-sequences of your PC in order to be
completed. Close all active applications before starting to install device drivers.
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6 Adjustment of Windows Settings

6.1 ‘User Account’ Settings

An computer account with sufficient user rights is required for IMAC L. This account will be
used to setup an OS for ‘AutoLogin’. If the account ‘Admin’ does not exist, create a new
account as follows. Otherwise (if it should already exists) adjust it's properties:

- Clickon ‘Start > Settings - User Accounts’

The following dialogue will appear :
=% User Accounts EI@”E

|3

Learn About

(2] User accaunts Pick a task...

@ User account types
@ Switching users Change an account

Create a new account

Change the way users log on or off

or pick an account to change

Master
I" Computer administrator
; Password protected

- Click on ‘Create a new account’

The following dialogue will appear :

- User Accounts

Name the new account

Type a name for the new account;
[2dmir] |

This name will appear on the Welcome screen and on the Start menu.

- Enter the Name ‘Admin’ in the entry field
- Click on button ‘Next’
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2 The following dialogue will appear :
T heaine AEES
]
Learn About !
S e Pick an account type
(®) Computer administrator () Limited
With a computer administrator account, you can;
# Create, change, and delete accounts
& Make system-wide changes
# Install programs and access all files =
[ < Back] L Create Account ] [Cancel ] =
w
3
4
5 - Clickon ‘Computer administrator’ radio button
6 - Click on button ‘Create Account’
7
8 You are back to the ‘User Accounts’ Dialogue:
-£ User Accounts |:||E||X|
b
Learn About =
(@) User accounts Pick a task...
@ User account bypes
@ Switching users Change an account
Create a new account
Change the way users log on or off J
or pick an account to change
Master Admin
i Computer administrator = - = Computer administrator
: ) Password protected -
»
9
10
11 - Click on ‘Change an account’
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1
2 The following dialogue will appear :
-% User Accounts |Z||§| E
Related Tasks 5
B e Pick an account to change
Learn About
@ Master Admin
User accounts Computer administratar Computer administrator
Pazsword protected ﬂ
Guest
Guest account is off
3
4
5 - Clickon ‘Admin’ icon
6
7 The following dialogue will appear :
-£ User Accounts |Z||§||z|
-
Related Tasks " 2
What do you want to change about Admin’'s
Zhange another account
Create a new account accoun t?
Change the name Admin
ﬂ Computer administrator
Create a password
Change the picture
Change the account type
Delete the account
b
8
9
10 - Click on ‘Create a password’
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The following

- User Accounts

Learn About

@ Creating a secure password

[}j Creating a good passward
hiirk

@ Remembering a password

dialogue will appear :

(=13

Create a password for Admin's account

‘fou are creating a password for Admin, If you do this, Admin will lose all EFS-
encrypted files, personal certificates, and stored passwords for Web sites or
network resources.

To avoid losing data in the future, ask Admin to make a password reset floppy disk.

Type a new password:

Type the new password again to confirm:

If the password containz capital letters, they must be typed the same way every time,

Type & word or phrase to use as a password hint:

|Place & password hint hers |

The password hint will be visible to everyone wha uses this computer.

[ Create Password ,] [Cancel]

- Carefully enter a new password (twice) and select a suitable passwort hint. Observe,
that Windows passwords are case-sensitive!
- Take a written note of the selected password and put it to your - project

documentation !!
- Click on
- Close the
- Click on
- Reboot your PC.

‘Create a password’
‘User Accounts’ dialogue
‘File > Close’ to close ‘Control Panel’

- During this reboot log in as ‘Admin’ with the password as defined here.
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6.2 ‘AutoLogin’ Settings

IMAC L Operator Stations have to start up Windows XP without prompting for a login (to
make an OS operational again without operator interference e.g. after a power loss). Use this
procedure to set this up:

- Click on ‘Start > Run’

The following dialogue will appear :

— Type the name of a prograr, Falder, document, ar
= Internet resource, and YWindows will open it Faor you,

v

[ Ok H Cancel H Browse. .. ]

-  Enter ‘control userpasswords?2’
- Click on ‘OK’

The following dialogue will appear :

User Accounts

Users l Advanced |

Idse the list below to grant or deny users access to your
computer, and ta change passwords and okher settings,

[ JUsers must enter a user name and password o use this computer,

Users For this computer:

User Mame Group
Admin Administrators
Adminiskrator Administrators
ASPNET Users

Passwiord For Admin

g To change the passward For admin, click Reset Password,

PLES _: Hasswoarg

O ][ Cancel ][ Apply
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- Deselect (uncheck) ‘Users must enter a user name and password ...’
- Clickon ‘Apply’

The following dialogue will appear :

Automatically Log On

i ¥ou can set up your computer so that users do not have ko bype a
user name and password ta lag on. Tao da this, specify a user that
will be autormatically logged on belov;

Lser name: Adrmin

Password; [

Confirm Password; b Ll

[ (] .4 l [ Cancel ]
- Enter User name ‘Admin’ (see above)

- Carefully enter the ‘Admin’ password (twice). Mistyped User name or passwords will
not be immediately detected (this happens only during next boot).

- Clickon ‘OK’ to close ‘Automatically Log On’ dialogue

- Click on ‘OK’ to close the ‘User Accounts’ dialogue

Then Reboot the PC in order to check, if AutoLogin works properly:
- Click on ‘Start > Turn Off Computer... > Restart’.
The OS should reboot without requesting a username or password during Windows start.
If a failure message is displayed during booting and AutoLogin is not successful, it is very
likely that in the ‘Automatically Log On’ dialogue you entered either the User name or at least

one of the passwords wrongly. In this case repeat the above procedure with the correct
entries.
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6.3 ‘Screen Resolution’ and ‘Refresh Rate’ Settings
- Clickon ‘Start > Settings - Control Panel'.
- Double-Click on ‘Display’
- Click on tab ‘Settings’

You should see the following ‘Display Properties’ dialogue :

Display Properties

.Themes Desktop | Screen Saver. .ﬂ.ppearance| Settings

Dizplay:
Default Manitar an InkellR] 8286506 Graphics Contraller
Screen rezolution Color guality
Less J—— More [Highest (32 bl w |
1280 by 1024 pixels 1N ' =

[ Troubleshoot. .. ] [ Advanced ]

[ k. H Cancel ] Apply

- Adjust the Screen Resolution to ‘1280 by 1024 pixels’
- Adjust Colors to ‘Highest (32 bit)’
- Click on ‘Apply’

Hint : If these settings are not available, check your hardware and the correct installation of
all required drivers for your graphics card and your monitor.
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The screen will flicker for a short time. Then the screen will reappear with the new (higher)
screen resolution. The following dialogue will appear :

Monitor Settings @

& | ‘four deskkop has been reconfigured, Do you want bo keep

,\:r," these settings?

Reverting in 10 seconds

You now have 15 seconds to click on ‘Yes’ to accept the new settings. Otherwise Windows
will automatically revert to the previous settings.

Hint : If, after clicking on ‘OK’, the screen will either stay black or display ‘garbled’ contents,
your Monitor is not capable to display the required screen resolution. Wait for 15
seconds. Windows will automatically revert to its previous settings. Replace your
monitor and retry !

The ‘Display Properties’ dialogue will still be displayed after this setting (although the
dialogue will appear smaller now due to the increased screen resolution.

- Click on button ‘Advanced’
- Click on tab ‘Monitor’

Hint : the dialogue that appears if you click on ‘Advanced’ will vary in its appearance
depending on the graphics card driver installed in your PC. Compared to the
screenshot above, more or other ‘tabs’ may appear. Nevertheless there should always
be a ‘Monitor’ tab available.

The following dialogue will appear :

Default Monitor and Intel{R) B2B65G Graphics Contro... E]E

~ Calor Management [ E IntellR] Extreme Graphics 2
General | Adapter | Manitar | Troubleshoot
tonitor pe

.I Default Monitor

Moritor settings

Screen refresh rate:

60 Hettz |

ak. ] [ Cancel
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Adjust the ‘Refresh Frequency’ of your monitor to a suitable rate :

- For VDU-based monitors higher settings are usually better (Frequencies >= 85 Hertz
are assumed to be flicker-free). The maximum permissible rate for your monitor
depends on the screen resolution you have selected and your monitors ‘video
bandwidth’. If the checkbox ‘Hide modes ..." is checked, Windows will usually just
offer those refresh frequencies which your monitor is able to handle.

- If you have a TFT-type flat screen monitor always keep this setting at ‘60 Hertz’ !

Hint : After adjusting the screen resolution and refresh frequency it is usually necessary to re-
adjust your monitors settings for picture ‘SIZE’ and ‘POSITION’. Adjust these settings
so that the display will neatly fit into the monitors display area. Consult your monitors
manual for more information on how to do this.

- Click on button ‘Apply’ to accept your changed settings.

The screen will flicker for a short time. Then the screen will reappear with the new (higher)
refresh frequency. The following dialogue will appear :

Monitor Settings g]

& | ‘our deskiop has been recanfigured. Do you wank bo keep

g/ these settings?

Reverting in & seconds ves ] I Mo

You now have 15 seconds to click on ‘Yes’ to accept the new settings. Otherwise Windows
will automatically revert to the previous settings.

Hint : If, after clicking on ‘OK’, the screen will either stay black or display ‘garbled’ contents,
your Monitor is not capable to display the selected refresh frequency. Wait for 15
seconds. Windows will automatically revert to its previous settings. Retry with a lower
refresh frequency !

- Click on ‘OK’ to close ‘Monitor Settings’ dialogue
- Clickon ‘OK’ to close ‘Display Properties’ dialogue
- Click on ‘File > Close”’ to close ‘Control Panel’
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6.4 ‘Screen Saver’ Settings

Hint : For Operator Stations (OS) used for control and monitoring, the use of screensavers or
monitor power saving functions is_generally not permitted. Alarm- or other important
display information might be hidden behind an active screensaver ! The use of screen
savers and / or energy saving modes for VDUs is only permitted for Engineering PCs
not serving as an OS.

- Click on ‘Start > Settings = Control Panel'.
- Double-Click on ‘Display’
- Click on tab ‘Screen Saver

You should see the following ‘Display Properties’ dialogue :

Display Properties

__Themes Desktupg Screen Saver | Appearance | Settings

b onitor powveer

To adjuzt monitor power settings and zave energy,

chick Power,
Power...

[ 2k, H Cancel H Apply ]

Select (none) for an OS PC.

For other PCs select a Screensaver according to your preferences.
Modify this Savers specific settings, if desired (button ‘Settings’)
Adjust the waiting time according to your preferences.

Please adjust the ‘Energy saving features of your monitor’ in the lower part of this dialogue
(button ‘Power ...") according to your preferences. For IMAC L OS PC s power saving has to
be switched OFF here !

- Click on button ‘Apply’ to accept your changed settings.
- Clickon ‘OK’ to close ‘Display Properties’ dialogue
- Click on ‘File > Close’ to close ‘Control Panel’
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6.5

‘Power Options’ Settings

For use as an IMAC L OS the Power Saving options of Windows XP have to be adjusted as

follows:
- Click on

The following dialogue will appear

Power Options Properties

‘Start > Settings - Power Options’.

Power Schemes I.-’-‘-.u:lvanu:ed_' Hibemnate | UPS

the selected scheme.

Paower schemes

& Select the power scheme with the most appropriate settings for
thiz computer. Mote that changing the zettings below will rmodify

| Home/Dffice Desk

v
|

Save bz ] [

Delete ]

Settings for Home/Office Desk power scheme

Turn off ronitor:

| Mewer

Turn off hard disks: W |
Spztem standby: | Mewer 1|
[ (] 8 ] [ Cancel ] [ Apply ]

- Select Power scheme

- Modify all three settings to
- Click on button

- Clickon Tab

‘Home/Office Desk’.

‘Never’

‘Apply’
‘Advanced’

to accept your changed settings.
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The following dialogue will appear :

Power Options Properties

.F'DwerSchemes ..ﬁ.dvanced IHiI:uernate .LIF'S

“r'i_?;j Select the power-zaving zettings you want to uze.

O ptions
[ &lways show icon on the taskbar

(] Prampt far pazsword when computer resumes from standhby

Fower buttons

When | press the power button on my computer:

I:ZI o hiothing

[ ak H Cancel H Apply ]

- Deselect (uncheck) ‘Prompt for password when computer resumes ...”
- Select ‘Do nothing’ from the ‘Power buttons’ combo box.
- Click on button ‘Apply’ to accept your changed settings.
- Clickon ‘OK’ to close ‘Power Options’ dialogue
- Click on ‘File > Close’ to close ‘Control Panel’
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6.6 ‘IP Address’ Settings

All Operator Stations, Engineering PCs and PCUs will need to have a fixed and unique IP
address assigned to them according to the following Scheme :

Type of Device IP Address assignment

PCUs 223.223.000.00x (x =PCU-No.)
Operator Stations 223.223.000.10x (x =0S-No.)
Other Devices (e.g. Engineering PC) 223.223.000.20x (x = Device-No.)

The Subnet-Mask has to be : 255.255.255.0 for all devices !
Assignment of IP addresses using DHCP servers is not allowed for IMAC L components.
To modify the IP address assignment of the PC proceed as follows:

- Click on ‘Start > Settings = Control Panel'.
- Double-Click on ‘Network Connections’

The following dialogue will appear :

‘.“_"- Network Connections

File Edit ‘“iew Favorites Tools Advanced  Help -.t'
= .
@ Back - </ ﬁ‘ P ! Search b Folders v
Address | € Metwark Connections viEe
N = "
-' A Mame Twpe
-3
Network Tasks ) | LAN or High-Speed Internet

@ Create a new
conneckion

9 Set up a home or small
— office nebwork

M| AN-Conneckion LAMN or High-Speed Inter. ..

& Chanoe Windows
Firgwall settings

'ﬁ. Disahle this netwark
device

% Repair this connection W £ >

Intel{R) PROY 1000 CT Metwork Connection

- Double-Click on ‘LAN Connection’

Hint : If your PC should have multiple network cards, more than one entry will show up in this
list. Indentify the entries in this list and make sure to select the one to be used for the
IMAC L Ethernet Bus connection.
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The following dialogue will appear :

- LAN-Connection Staius

General | Support
Connection
Statuz: Connected
Druration: 40 dayz 21:11:16
Speed: 100.0 Mbpz
Activity
=
Sent yﬂ Received
= o
2
Packets; E7.479678 | 27229
Froperties _” Dizable
- Click on ‘Properties’

The following dialogue will appear :

- | AN-Connection Properties

General | Advanced |

Connect using:
EHE IntellR) PROA000CT Metwork Conn

Thiz connection uses the following ke

% Cliert for Microsoft MNetworks
.@ File athd Printer Sharing for Microsoft Metworks
@DQS Packet 5cheduler

Internet Protocal [TCPAR)
Description

Transmigzion Control Protocol/Intermet Pratocal. The default
wide area network, protocol that provides cormmunication
acrosz diverze interconnected networks.

] Show icon in notification area when connected
Hatity me when thiz connection hag limited or o connectivity

ok ] [ Cancel
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- Select the item ‘Internet Protocol (TCP/IPY
- Click on Button ‘Properties’

The following dialogue will appear :

Internet Protocol (TCP#IP) Properties

General

Y'ou can get P zettings azsigned automatically if your network, supports
thiz capability, Othenwize, vou need to agk your network, administrator for
the appropriate |F settings.

(7 Obtain an IP address automatically
(%) Usze the following IP address:

IF address: 223223000101 |
Subnet mask: o5 255 285 O |

Default gateray:

(&) Usze the following DMS server addresses:
Preferred DNS server:

Alernate DMS zerver:

I (]9 l’ Cancel ]

- Enter IP-address and subnet mask according to table above
(this example shows settings for the first IMAC L OS).
- Click ‘OK > OK - Close’ to close the properties windows
Then Reboot the PC in order to let these changes take effect:

- Clickon ‘Start > Turn Off Computer... > Restart’.
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6.7 ‘Automatic Updates’ Settings

For IMAC L Windows XP has to be installed with Service Pack 3 only. No additional
Hotfixes, Security Patches or other Windows Updates are allowed. Therefore Microsoft
Windows ‘Automatic Update’ is not allowed for IMAC L and has to be turned off:

- Clickon ‘Start > Settings - Control Panel'.
- Double-Click on ‘Automatic Updates’

The following dialogue will appear :

Automatic Updates @|

[ automatic Updates

Help protect wour P

windows can regularly check For important updates and install them For wou,
(Turning on Automatic Updates may aukomatically update Windows Update
software first, before any other updates,)

How does Automatic Updates works

(") Automatic {recommended}

: Automatically download recommended updates For my
computer and install them:

(") Download updates For me, but let me choose when ta install them,
(¥ Matify me but don't automatically download or install them.

(&) Turn of F Automatic Updates,

‘four computer will be maore vulnerable unless yvou install
updates regularly,

Install updates From the Windows Update Web site,

[w]'d l [ Cancel ] [ Apply ]
- Select ‘Turn off Automatic Updates’
- Click on button ‘Apply’ to accept your changed settings.
- Clickon ‘OK’ to close ‘Automatic Updates’ dialogue
- Clickon ‘File > Close’ to close ‘Control Panel’
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6.8 ‘Security Alert’ Settings

The settings for Windows alarms regarding security settings have to be modified in order to
avoid undesired alarms during the IMAC L operation:

- Clickon ‘Start > Settings = Control Panel'.
- Double-Click on ‘Security Center’

The following dialogue will appear :

¥ Windows Security Center EHE@

@ Security Center

Help protect your PC

&) Resources Security essentials
L, Security Center helps you manage your Windows security settings, To help probeck your computer,
make sure the three sscurity essentials are marked ON, IF the settings are nat ON, Follow the
= Get the latest security and virus recommendations. To return to the Security Center laker, open Conkrol Panel,
information from Microsaft What's new in Windows to help prokect my compuber®

= Check for the latest updates from

windows Update g3 Firewall @ ON

= Get support For security-relaked
issues

x . .
¢  Automatic Updates & OFF | &
= Get help about Security Canter L
Automatic Updates is turned off. Your computer is more vulnerable to viruses and other
= Change the way Security Center security threats, Click Turn on Automatic Updates to have Windows automatically keep your
alerts me cornpLber cprenkt with imporkant updates. How doss AUtomatic pdstes help protect
computer?®

Turn on Automatic Updates

‘windows did not find antivirus software on khis computer, Antivirus software helps pratect
yaur computer against viruses and ather security threats, Click Recommandations For
suggested actions you can take, How doss antivirus softwars help probect my computer?

Mote: Windows does nat detect all antivirus programs.

Recommendations. ..

Manage security settings for:

- Click on ‘Change the way Security Center alerts me’ (left, bottom).

The following dialogue will appear :

¥ Alert Settings

’}' Security Center

Alert Settings

[CIFirewall
Alert me if my computer might be at risk because of mey Firewall
settings

[] automatic Updates

alert me if riv compuker might be at risk because of my Aukamatic
|pdates settings

|:| Wirus Protection
Alert me if iy computer might be at risk because of my virus
protection software settings

[ Ok ][ Cancel ]

Deselect (uncheck) all three items in this dialogue
Click on ‘OK’
Close the ‘Security Center’ Window
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6.9 ‘Firewall’ Settings

The settings for the Windows Firewall have to be modified in order to avoid undesired
malfunctions of the IMAC L operation:

- Clickon ‘Start > Settings > Windows Firewall’.

The following dialogue will appear :

"= Windows Firewall

| General | Exceptions | Advanced |

z helping to pratect yaur PC

Windows Firewall helps protect vour computer by preventing unauthorized uzers
from gaining acces: to vour computer through the Intemet or a network.

@ () On [recommended])

Thiz zetting blocks all outside sources from connecting to this
computer, with the exception of thoze zelected on the Exceptions tab.

| Select this when you connect to public netwarks in lezs zecure

lozations, such ag airports, You will not be notified when Windows
Firewall blocks programs. Selections on the Exceptions tab will be
ignored.

@ (=) Off [not recommended)

Avoid uging thiz setting. Tuming off Windows Firewall may make this
computer more vulherable to viruges and intruders.

Wihat elee should | know about Windows Firewal?

I (]S H Cancel l

- Select ‘Off (not recommended)’
- Click on ‘OK’ to close ‘Windows Firewall’ dialogue
- Click on ‘File > Close’ to close ‘Control Panel’
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6.10 ‘Daylight Saving’ Settings

With IMAC L the setting of local time is up to an operator with sufficient user rights — or to a
ships master clock (if there is one and it is connected to IMAC L). This requires, that the
Windows feature for ‘Automatic clock adjusting for daylight saving’ has to be turned off:

- Click on
- Clickon Tab

The following dialogue will appear :

Date and Time Properties

| Date & Time | Time Zone | Internet Time

:I{GMT+EII:EIEI:| Amsterdam, Berlin, Bern, Rome, Stockholm, Yienna v

[ ]automatically adjust clock for daylight saving changes

‘Start > Settings - Date and Time’
‘Time Zone’

| ok

][ Zancel ][ Apply

- Deselect (uncheck)
- Click on button

- Click on

- Click on

‘Automatically adjust clock ...’

‘Apply’ to accept your changed settings.
‘OK’ to close ‘Automatic Updates’ dialogue
‘File > Close”’ to close ‘Control Panel’
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6.11 ‘Desktop Cleanup’ Settings

Windows XP has a function to automatically suggest a ‘cleanup’ of the desktop for icons on
the desktop that have not been used for more than 60 days. If an operator should agree to
such an operation, all these icons will be transferred to a folder and no longer be accessible
directly from the desktop.

For an IMAC L OS it is very likely, that such a function would remove all icons from the
desktop. Therfore this function has to be switched off.

To switch Desktop Cleanup off, please proceed as follows:

- Clickon ‘Start > Settings = Control Panel'.
- Double-Click on ‘Display’

- Clickontab ‘Desktop’

- Click on button ‘Customize Desktop...’

The following dialogue will appear :

Desktop Items

General. ' Web

Dezktop icons
[ ] My Documents by Metwork Places
] My Computer

- i - =
| 4 |
2 O 9 g
by Computer My Documentz My Metwark Recycle Bin Res
Flaces [Fuall] [1

£ | >

Change lcon... ] [ Restore Default

Dezktop cleanup

Desktop cleanup moves unuzed desktop itemns to a folder.

[] Run Desktop Cleanup Wizard every B0 days

[ Clean Deskiop Mow ]

[ ] l [ Cancel ]
- Deselect (uncheck) ‘Run Desktop Cleanup Wizard every 60 days’
- Click on ‘OK’ to close ‘Automatic Updates’ dialogue
- Click on ‘Apply’ in Window ‘Display Properties’
- Clickon ‘OK’ to close ‘Display Properties’
- Click on ‘File > Close’ to close ‘Control Panel’
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6.12 ‘Computer Name’ and ‘Workgroup Name’ Settings

For use with IMAC L, the computer names and the network Workgroup have to be set
correctly:

- Clickon ‘Start > Settings - System’
- Clickon Tab ‘Computer Name’

The following dialogue will appear :

System Properties

System Restare i Automatic Updates . Remote
Gemerasl | ComputerMame | Hardware Advanced

- Windows uzes the following information o identify your cormpuker
5 on the netwark,

Camputer descnptian: .

For example: "Kitchen Computer'’ ar "Mary's

Cormputer'',
Full computer name: 051,
Warkgroup: WORKGROUF

T uze the Mebwark, | dentification Wizard b join a Meatwark D
domain and create a local user account, click Metwork,

D,

T rename thiz computer ar join a domain, click Change.

& Changes will take effect after you restart this computer.

[ ]9 H Cancel l

- For ‘Computer Description’ enter ‘OSx’ (x = OS number) or ‘ENGINEERING’
- Click on button ‘Change’
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The following dialogue will appear :

Computer Mame Changes

Y'ou can change the name and the membership of thiz
computer. Changes may affect access to netwaork, resources.

Computer name:

051
Full computer name:
051,
M ember of
) Domain;
(=) workgroup:

|WEIFIKI3FIEILIF'| |

I ak. ][ Cancel ]

- For ‘Computer Name’ enter ‘OSx’ (x = OS number) or ‘ENGINEERING’

- Select (Check) ‘Member of ... Workgroup’

- Enter the Workgroup name ‘WORKGROUP’ in the bottom entry field.

- Clickon ‘OK’ to close ‘Computer Name Changes’

The following dialogue will appear :

Computer Mame Changes

\5) You must reskart this computer For the changes to kake effect,

- Click on ‘OK’ in this dialogue
- Clickon ‘OK’ to close ‘System Properties’ dialogue
- Clickon ‘File > Close’ to close ‘Control Panel’
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6.13 ‘Shared Access’ Settings

For IMAC L it is required to have a network sharing access to the ‘C’ partitions of all OSs.
This sharing access is used to distribute the IMAC L runtime files (*.DIS / *.DO) from the
IMAC L Engineering PC to all OSs.

It is required to enable this sharing according to the following procedure:

- Clickon ‘Start > Programs - Accessories - Windows Explorer’
- Right-Click on: Drive ‘C:\
- Select ‘Properties’ from the context menu that popped up

- Click on Tab ‘Sharing’

The following dialogue will appear :

Local Disk (C:) Properties

| General Tu:u:uls. Hardwarg; Sharing f_._I]tha

To protect vour compter from unauthorized access, sharing the
roat of a drive iz nat recammended.

1f unu understand the rizk, but still want bo share the oot of the

[ Q. l[ Canicel ]

- Click on ‘If you understand the risk ..., click here.’
(the dialogue will change it's appearance)
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- Enable sharing for ‘C’ by modifying the settings to be like this:

Local Disk (C:) Properties

| General Tu:u:uls. Hardwarg; Sharing f_._EJ uata

Local sharing and secunty

T

'—:‘g T zhare this folder with ather uzers of thiz computer
g

only, drag it to the Shared D ocuments folder.

To make this folder and itz subfalders private so that
only you have accesz, select the following check, bow.

Metwork sharing and security

# To share this folder with both network, users and other
WL users of thiz computer, select the first check box below
= = and type a thare name.

Share thiz folder on the nebwork:,
Share name: E

Allow network, ugers to change my files
Leamn more about sharing and security.

Ay ‘windows Firewall is configured to allow this folder to be shared
with ather computers an the network,

"Wiew your Windows Firewall zettings

[ k. H Cancel H Apply

- Click on ‘Apply’

The new settings are applied to drive ‘C:\' now. This may take a few moments. Then the
dialogue closes automatically and sharing for drive ‘C:\’ is enabled now.
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6.14 ‘Automatic Start’ Settings

Programs can be setup to be automatically started after Windows XP has booted. This
setting is typically used to cause IMAC L to be started automatically during the boot of a PC.
This is a necessary setting for an IMAC L OS. For IMAC L this setting can only been done,
after IMAC L has been installed. Nevertheless the basic setting procedure is described here,
as it is a setting of the Windows XP operating system.

To enter an item to the Windows XP startup procedure, please proceed as follows:

- Click on ‘Start > Programs’

- Point your mouse at ‘Startup’

- Right-Click on ‘Startup’. A context menu will open.
- Click on ‘Open’ in this context menu.

The Windows ‘Startup Folder’ will open :

& C:\Documents and Settings\Master\Start MenuPrograms\Startup g@”g\
Fle Edt W¥ew Favorites Tools Help &
Dt - @ - ¥ | Psearch [Brroes [

Address | [F) C\Documents and Settings|MasterlStart MenuiProgramsistartup v|EJ 6o
Name Size | Type Date Modified

File and Folder Tasks L

(2 Make & riaw Foldsr
| & Publish this folder to the
Wb

{2 share this folder

Other Places

) Programs

(L My Dacuments
| Shared Documents
i My Computer

& My Netwark Places

Details

0 objects (plus 1 hidden) 84 bytes g My Computer

Please copy do only shortcuts to programs / batches into this folder, not the programs
themselves.

To create a new link within the Startup folder:

- Right-Click to the empty location in this folder’s client area (on hand right side)
(a context menu will open)
- Click on ‘New’ - Shortcut’ in this context menu.

The following dialogue will appear :

Create Shortcut El

This wizard helps you ko create shortcuts ko local or
nekwark programs, files, Folders, computers, or Internet
addresses,

Type the locat

.
. | | Browse...

Click Mext to continue,
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- Enterthe [Drive]:\[Path]\[Filename] of the program to be started
(or use ‘Browse...’ function to locate it)
- Click on ‘Next’

The following dialogue will appear :

Select a Title for the Program E|

Type a name Far this shorkout:

Click Finish to create the shortcut,

[ < Bark. ” Finish ][ Cancel ]

- Click on ‘Finish’
- Click on ‘File > Close’ to close the ‘Startup Folder’

With the next PC reboot, the program(s) placed here will be automatically started.

© Siemens AG 2009, All Rights reserved ¢ | IS MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D35 / 97
IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



10
1"
12
13

14

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Installation of Applications
7 Installation of Applications
71 Adobe Acrobat Reader
- Insert the IMAC L Engineering System Install CD’ into the CD-ROM drive.
- Click on ‘Start > Run’
- Enter ‘D:\Acrobat\AdobeRdr80_en_US.exe’

(replace D with the drive letter of your CD-ROM drive).

The following dialogue will appear :

- Type the name of a program, foldet, document, ar
: Internet resource, and Windows will open it For wou,

Cpen: :FJ.-:ru:-I:-at'u'-\-:lu:-I:-e'EIIII en L5, exe

|

[ oK ][ Cancel H Browse. ., ]

- Click on ‘OK’

The Installation of Adobe Acrobat Reader 6.0 will start :

*2 Adobe Reader B - Setup

Flease wait while the Adobe Reader & Setup is being processed. This will take some time
depending on vour operating system and hardware,

Processing Adobe Reader & ... 387 W

(FRRewsRRRRRRRRRE RS )
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i Adobe Reader B - Setup

Destination Folder
Click Mext bo install o this Folder, or click Change tao install ko a different Folder.

Install Adobe Reader 8 to:
C:\Program FilestAdobe\Reader 5.0

WARNING: This program is protected by copyright law and international treaties,

[ Change Destination Folder... Mext = ] [ Cancel

- Click on ‘Next’ :
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i Adobe Reader B - Setup

i

Ready to Install the Program

Click Install ko begin the installation,

IF wou want o review or change any of your installation folder, click Back, Click Cancel to
exit setup,

< Back ” Install ] [ Cancel

- Click on ‘Install’

i Adobe Reader B - Setup

i

Installing Adobe Reader &

The program features you selected are being installed.

@ Please wait while setup installs Adobe Reader &, This may take several minutes,

Status: Writing system registry values
Key: \Software\Classes|.edn, Mame: Content Type,...: applicationfvnd adobe. edn

Estimated time remaining: 16 Sec,

i% Adobe Reader B - Setup

Setup Completed

Setup has successfully installed Adobe Reader 8. Click Finish to exit setup,

[Launch Adobe Reader &

< Back

- Click on ‘Finish’
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7.2 File Packing Utility

IMAC L requires a file packing utility for engineering and installation, that is capable of
creating and handling ZIP files including ‘File Paths’. Install a file packing tool of your choice
with it's standard options. Typical possible utilities are:

- TZip Open source freeware, commercial use is allowed
- WinZip Commercial software (license required)

The ‘IMAC L Engineering System Install CD’ contains 7-Zip version 4.65. More recent
versions (if available) can be downloaded from http://www.7-zip.org.

This Manual describes the installation of 7-Zip:

- Insert the IMAC L Engineering System Install CD’ into the CD-ROM drive.
- Click on ‘Start > Run’
- Enter ‘D:\7-Zip\7-Zip.exe’

(replace D with the drive letter of your CD-ROM drive).

The following dialogue will appear :

ool
Choose Install Location P
Choose the folder in which to install 7-Zip .64, R 3 y

Setup will install 7-Zip 4.64 in the Following Folder, Toinstall in a different Folder, click Browse
and select another Folder. Click Install bo start the installation,

Destination Folder
[ Browse... |
Space required: 2.9ME
Space available: 7.1GE
WAL T -ZipLard
s _|
H € )
- Click on Install
ol
Completing the 7-Zip 4.64 Setup

Wizard

7-Zip 464 has been installed on yvour computer,

Click Finish ta dose this wizard,

< Back I Finish I Cancel

- Click on ‘Finish’
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7.3 Microsoft Excel

This software is required for Engineering PCs only!

IMAC_L will require Microsoft Excel (Version Excel 2000 or Excel 2003, NOT 2007!) for
editing the IMAC L measuring points list on engineering PC’s. This Installation Example will
show the installation of a complete Office 2000 (small business edition) package.

- Insert the ‘Microsoft Office 2000 installation CD into the CD-ROM drive. The
installation will start automatically:

Windows Installer i

| Preparing to install..

5

Cancel

- Enter the Microsoft Office ‘CD-Key’ (to be found on a sticker, which is in most cases
affixed to the CD-ROMs protective envelope)

lcome

SETUP

Please enter your Product Key.
Certificate of Authenticity

License and Support Infarmation ‘our 25-character Product Key can be Found on vour Certificate of Authenticity,

Ready to Instal

Instaling Cffice D Key

Help Cancel < Back | Mext == I
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- Click on Button ‘Install Now’

i'&%‘ Microsoft Dffice 2000: Ready ko Install j o [ 553

Setup is ready to install Microsoft Office 2000 Small Business.

Click Install Mow o begin installing Office. ..

SETUP

Install Now

Customer Information Install Office 2000 at C:\Program FilesiMicrosoft Office)

License and Suppart Infarmation

Ready to Install

....or click Custamize ko make mare choices about your Office installation.
Instaling Cffice
Customize...

Choose the installation location, indicate whether or not to keep
previous versions of Office, and specify which features ta install now.

Help | Cancel | << Back | [EXE =2 |

- The installation progress will be displayed.

il Installing Microsoft Dffice 200D ' =10 x|

Please wait while Windows configures Microsoft Sffice 2000

Inskalling Microsaft Qffice 2000..,

| _ Cancel

- Click on Button ‘OK’ to finish the installation

i‘é Microsoft Office 2000 Setup x|

Microsaft CFfice 2000 Small Business setup completed
successfully,
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7.4 WinLock Software

This software is required for Operator Stations only!

Its purpose is to prevent, that an operator can use an Operator Station as a standard PC.
This is highly undesired due to several important reasons.

Therefore all standard key combinations and functions, that can be used to perform a task-
switch or the starting of any additional applications have to be prevented. WinLock performs
this set of interlocks and gives password protected access to Windows. Shutting down a PC
will still be possible.

This level of protection is usually only required after commissioning and delivery of a project.
Before this time (during engineering & commissioning) the Winlock protection may
sometimes be annoying, because it may be frequently necessary to access the Windows
desktop and Windows functions.

Important Hint:

The IMAC L standard templates will contain a key combination (CRTL-X, ALT-F4) to easily
terminate the HMI application during engineering and testing. In order to completely secure a
OS against inadvertent or intentional operator tampering, these keys have to be removed as
well:

PMU.EXE -> AbvBrowser - File 2 ‘Global Events’ > ‘K C X UsrExit()’ > Delete).
PMU.EXE -> AbvBrowser - File - ‘Global Events’ > ‘K A F4 UsrExit() - Delete).

Important Hints regarding the WinLock password:

e Remember (or better write down) the password used for WinLock. Without this
password no ‘usual ways’ to exit the HMI application will exist. Put this password to
your internal project documentation, because it might become important for later
service and repair. WinLock is quite resistive to attempts of intrusion. Be careful !

e Don't use trivial passwords (like ‘IMAC L’). Stick to standard procedures for choosing
secure passwords (min. length of 8, mix of letters, digits and special characters).

e This password should be kept secret. If a customer insists on knowing this password,
the possible consequences should be made clear (loss of warranty, risk of
malfunctions). In any case this is a ‘Chief Engineer Only’ password ! The customer
may not change this password (or Siemens Service will not have access to the OSs
any more).
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To install WinLock (unregistered Demo version from ‘IMAC L Engineering System Install CD’:
- Insert the IMAC L Engineering System Install CD’ into the CD-ROM drive.

- Clickon ‘Start > Run’
- Enter ‘D:\Winlock\Winlock.exe’

(replace D with the drive letter of your CD-ROM drive).

- Click on ‘OK’
Run 21|

Type the name of a program, Folder, document, or
Internet resource, and Windows will open it Far wou,

Open: 2 inlockhwinle

=

Ok I Cancel | Browse, ., |

Click ‘Next’ to continue :

]ic,il Setup - WinLock N o ]

Welcome to the WinLock Setup Wizard

Thig will inztall WinLock 4.11 on your computer.

It iz recommended that vou close all other applications before
continuing.

Click Mext to continue, or Cancel to exit Setup.

WARNING: This program is protected by copyright law and
international treaties.

Unauthorized reproduction or distribution of thiz program, or any
partion of it, may result in severe civil and criminal penalties, and
will be prozecuted ta the mazimum extent pozsible under law,

Met > I Cancel

Click ‘Next’ to continue :

il

Select Destination Location
Where should ‘WinLock be installed? ; /
B ™\

G Setup will inzstall WinLock into the following foldar.

To continue, click Mest. If vou would like to zelect a different folder, click Browse.

Browse... |

Atleast 1.2 MB of free disk space is requirad.

< Back I st > I Cancel
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Click ‘Install’ to continue :

il setup - WinLock N o ] 5|
Ready to Install
Setup iz now ready to begin installing ‘WinLock on your computer,
| N

Click. Install to cantinue with the installation. or click Back if you want o review or
change any settings.

Destination location: ;I
C:\Pragram FileshiwinLaock

L off

< Back I Install I Cancel I

Click ‘Finish’ to finalize installation :

]ig‘-‘- Setup

N [EEE
Completing the WinLock Setup Wizard

Setup has finizhed instaling “wWinLock on wour computer. The
application may be launched by selecting the inztalled icons.

Click Finizh to exit Setup.
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1
2 7.4.2 Winlock Settings

To configure WinLock, double-Click on the WinLock Icon in the right section of the

Windows Task Bar. If you are using a unregistered Demo version, a splash screen will hint

you to this fact :

= ¢ This iz evaluation version of WinLock. Some advanced
1 5 features of WinLock are dizabled.
- Click on the "Register Mow 1" button to register WinLock or
click on the "More Info_._" button to read more about
WinLock registration.
|

6

If Winlock has been installed and activated before on this PC, it will request the password,

that has been set the last time (even if Winlock has been de-installed in the meantime):

Password
’:;?v)s Enter pazsword to configure ‘WinLock.
Ixme:1
Ok I Cancel | Help |
9
10

11 WinLock has to be configured according to the following screens (navigate through the
12 menus one by one by clicking on the tabs and icons on the left side of the window. Copy the
13 settings as shown. If settings are modified, be sure to not lock out yourself.

14 Tab ‘General’ = Icon ‘Protection’ :

l5ix
Protection Wiew Profie Tools Help
US| Protection
o
Protection ‘ f‘ WII?L k. bl ?..‘?Hd protecting your system.
== [ iore Cancel
3 d; P. d Help |
Settings E_‘?\)) Paszword I”"“
i LConfirm password Ix"’“
‘sa.‘i) Options
Logging M [ Adtomatically tun on protection on startup
L I~ Prompt for the password on startup
¥ Show password prompt on top of the other windows
™ System monitoring
System ™ Hide tray icon
o Priority INolma\ bl
Access
15 | 574 Enabled
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Tab ‘General’ - Icon ‘Settings’ :
- For field ‘Protection’: Click into this field, hold down the ‘ALT’ key and press ‘F11’
- Do not modify this setting ‘ALT+F11’, because most other keys are used by IMAC L !

=100 %]
Protection Wiew Profie Tools Help

£ WinLock Evaluation Yersion

o
Pratection %ﬂ; Rifpeties INoneI Cancel
,ﬁ Pratection IA" +F11 |
t @ . Help
e Miscell
Settings ﬁ [~ Enable Shutdown Windows menu
. =1 [T Include password in settings profile
W )
Logging
System
Lock
Access
Wﬁ Enabled |
¢ ’ ‘ H L
Tab ‘General’ - Icon ‘Logging’ :
£ WinLock Evaluation Yersion =1oix|

Protection Wiew Profie Tools Help

General Loggi“g

o
3 [ Enable ok
Pratection Femave the check-mark from an event to prevent it from S
being logged.
;ﬁ [ File created Select Al | Help
e [ File changed
Settings L] File renamed
[ File delated
3 [] Folder created
\y [ Felder renamed
[] Folder deleted
Logging L1 Folder updated
L] Folder shared
[ Folder unshared
[ Media inserted
L] Media removed
] User logged Yiew Lag |
System
il 7 [ Limit logging to |10 _Ij events
oc
Access
Wﬁ Enabled |

Tab ‘System’ - Icon ‘Security’ :

X

$: WinLock Evaluation ¥ersion ;IEI_I

Protection Wiew Profie Tools Help

Security

System

G |
-
@J r E! [T Block desktop [~ Disable Explorer contest mernu

e : r [T Don't save settings on egit Esnes

N

Start Menu and

I~ Dizahle Registy Editor
I~ Hide File menu
I~ Hide Falder Options menu

[ Disable programs on Settings menu
[~ Disable HTML wallpaper
[~ Disable changing wallpaper

Pl

Help

Tiaskbal [~ Disable display properties [~ Disable DOS applications
ﬁ [~ Digable Map/Disconnect ¥ Disable Windows Update
M;;SE T Windows NT}'ZI]I]I]."XP
Keyboard ¥ Disable Task Manager ¥ Disable Change Password
[¥ Dizable Contral Panel ¥ Dizable &dd/Bemove Programs
=l [¥ Disable Lock Computer [~ Djsable command prompt
Lock
Wﬂ Enabled
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Tab ‘System’ - Icon ‘Start Menu and Taskbar’ :

inLock Evaluation ¥ersion i = 1o i|

X

Protection Wiew Profile Tools Help

Start Menu Task

System
Start menu -DK
@J ’ Remave the check-mark from an item to prevent it from being
5 \ displayed in Start menu. Cancel
Security ] Fiur Hide &l 3
- im—— | _teb |

] Logalf
‘, Shutdown Shaw All

Help
Stal_lt_:ir‘;gland Documents
2

% Taskbar
Mouse and <8 [T Hide Start button [~ Disable Taskbar customization
Keyboard [~ Hide Switch bar [~ Lock Taskbar's toolbars

LI I Hide Tray contest menu
Lock
|—5;-;§ Enabled |

Tab ‘System’ = Icon ‘Mouse and Keyboard’ :

inLock Evaluation ¥ersion

=lolxi|

Protection Wiew Profie Tools Help

Mouse and Keyboa

System
o
@:' 3o Remove the check-mark from a hat key ta prevent it fram being
3 G2 blacked. In'Wwindows 35/38/Me click Block All to disable all hat Cancel
Security keys at once.
[k 3 hot key Block All Help:
&lt+T ab hot key

Start Menu and
Taskbar

Al+Ezc hot key

Alb+F4 hot key _lg"ab'a 2l
Wiindows kep

Applications key

T Mouse
5

t:’}' Remave the check-mark from a mouse button to prevent it fram
Mouse and L being blocked. In'windows 95./98/Me click Block Al to disable
Keyboard all mouse buttons at once.

: [ Left Buttan Block &1l
;\% ;l [_] Right Button -
Middle Buttan Enable &l
Lock [ twheel =

Fﬁ Enabled [

Tab ‘System’ - Icon ‘Drives’ :

inLock Evaluation ¥ersion

X

=100 |

Protection Wiew Profie Tools Help

Drives

System

Fiemove the check-mark from a dive to prevent the dive from being oK.
5 ;I displayed in My Computer and Explarer. -
= CAEE—. e Hide All Cancel
Mouse and E B _—I 4'
Keyboard Wl C: Help
VD Show &l LI
M E
vl F:
M G:
Drives W H:
M1
] J:
MK,
M L:
] M:
el M:
% 0:
v P
b @ |
Lock
E"_ﬂ Enabled |
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1 Tab ‘System’ - Icon ‘Boot’ :

£ WinLock Evaluation ¥ersion _ y =1oix|

Protection View Profie Tools Help

Boot

System
;I Mote: boat options available in‘wWindows 95/98/Me only.
~!“‘ 5 [T Enable
; i Cancel |
Mouse and Boot optiong

Keyboard

[~ Disable Cte+C during boot Help

[~ Dizable safe mode
I~ Dizable multi-boat [~ Disable hoot ta a command prompt
Drives I~ Disable boot menu [~ Lock system files

Boat

«

Lock

2 |7~ﬂ Enabled |

3 Tab ‘Lock’ = Icon ‘General’ :

f;; WinLock Evaluation ¥ersion _ y ;IEIEI

Protection Wiew Profie Tools Help

System

| [~ Enable oK
Interval

5 Cancel
i ';) |2 _I; hours and IED _Ij minutes ﬁ_\l

General & &pply new value

Mode

% E

o

% Shutdown  Logoff
Startup ¥ Lock after reset

[¥ Dizable timer after unlock

[.7

Natification

Access

4 Wﬂ Enabled [

5 - Click on ‘OK’ to save your settings

Enabling / disabling Winlock will from now on be possible by pressing ‘ALT+F11’ (toggle).
Winlock will ask for the password you have set before performing this operation. The current
Winlock status is displayed with the WinLock icon appearance in the Windows Task Bar.

© 0o N o
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7.5 Simatic Manager Software

This software is required for Engineering PCs only.

Simatic Manager software ‘Step 7 V5.3’ (SP 3) or higher is required on the IMAC L
Engineering PCs. You will require the appropriate software package including at least one
license (authorization disk / USB-stick). Your ‘IMAC L Engineering System Install CD’ does
not include any Simatic software packages.

Warning ! If more than one programmer will work on one specific project, it is common
practice to transfer single modules (e.g. function blocks or data blocks, zipped to an archive)
from one computer to another and thus from one Step7-project to another. If you are
planning to do this, it is absolutely necessary, that all computers used to handle such a
‘shared’ project will use precisely the SAME VERSION AND SERVICE PACK of the Simatic
Manager Software ! Ignoring this can lead to data inconsistency or even data loss !

This description will show, how to install and configure Step 7 V5.3 as the
‘Simatic Step 7 Prof. 2006’ edition (including SP 3). If your version does not include SP3, you
will have to install this service pack separately. For new hardware you may need a Hardware
Support Pack (HSP) for your Simatic Manager Software. These HSPs can be downloaded
from the Simatic Support Web-Pages. Please observe, that the HSP has to match the
version of your Simatic Manager package !

7.5.1 Installation of Simatic Manager

- Insert the ‘Simatic Simatic Step 7 CD’ into the CD-ROM drive. . The installation will
start automatically.

-

" Setupsprache: Deutsch
f* Setup language: English
{7 Langue dinstallation: Frangais
™ Idioma de instalacidn: E spafiol

" Lingua di installazions: |taliano

SIEMENS

Mext > | Cancel |

- Select your language (of the install program). Click ‘NEXT’ to continue : :
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Product Notice
Product notes dl&;’é@ B
L —

The product notes contain important information o installing and using this product.

we recommend you read these notes before installing

| want to read the notes

< Back MNewt > I Cancel |

- Click on Button

Components

Programs to be i

[ Aciobat Reader 5.0 20 MB The &crobat Reader iz used to
STEP 7 W5 3incl 5P1 290 ME 1ead the electronic manuals,
[A57-5CL va3 44 ME

ST GRAPH va.3 40 ME

[ 57-PLCSIM VE.3 18 ME

[Z] Autemation License Manager ¥1.1 incl SP1 10ME

Estimated installation time:
00:37 [hbvmm)

Required on C: 432 Mbytes

Available on C: 0054 Mbytes

< Back Mext > I Cancel

‘Next’ to continue

IMAC L Automation
Installation of Applications

- Select components to install (at least ‘Step7 V5.3’ has to be selected)

- Click on Button

STEP 7 ¥5.3 Installing....
STEP 7 V5.3 5P1

57-5CL V8.3

57-GRAPH 5.3

S7-PLCSIM 8.3

Automation Licenze Manager ¥1.1 incl. 5P1

Abort I

‘Next’ to continue
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{15 STEP. 7 Setup |Z|

Welcome to the Setup for
STEP 7 ¥5.3

The Installshield(R) Wizard will install STEP 7 on your
computer, To continue, click Mext,

WARNING: This program is probected by copyright and
inkernational treaties,

SIEMENS

< Back | Next» [ Cancel

- Click on Button ‘Next’ to continue

S.STEP 7 Setup

Readme File

Product notes display

The readme file contains important information on installing and using the software.,

We recommend you read this before installation,

T want to read the notes ]

IF you want to read the information later, you will find it in the Stark menu of your computer
after installation.

< Back ][ Mext = ] [ Canicel

- Click on Button ‘Next’ to continue

il STEP 7 Setup

License Agreemenkt

Flaase read the Followi

Please note;

S

This software is protected under German andfor US American Copyright Laws and
provisions in international treaties. Unautharized reproduction and distribution of
this software or parts of it is liahle to progecution. twill he prosecuted according to
criminal as well as civil law and may result in severe punishment andior damage
claims.

Flease read all license provisions applicable to this software before installing and
using this sofftware. You will find themn after this nate.

Ifyou purchased this software on a CD marked as "Trial-Yersion" ar together with
another licensed software foryou, this software may only he used for test and

I

(&)1 accept the kerms in the license agresment

()1 do not accept the kerms in the license agresment

Trs

< Back ]L Mext = ] [ Canicel

- Check the ‘l accept ...’ radio button
- Click on Button ‘Next’ to continue
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{5 STEP. 7 Setup

Customer Information

Please enter the Followin

User Mame:

Drganization:

iSiemans AG

[ < Back ]L Mext = ] [ Cancel ]
1
2
3 - Enter your name and organisation
4 - Click on Button ‘Next’ to continue
5
{5 STEP. 7 Setup
Setup Type
Choose the setup'iyp
B |
Crmal AR IR R
disk space.}
O Miniml Blbddiel bl
space.)
{5 Ouom S e e
Install STEP 7 to:
Ci\Program FilestSiemens\Step?y
[ Memoary ] [ < Back ]L Mext = ] [ Cancel ]
6
- Select ‘Typical
- Click on Button ‘Next’ to continue
10
{5 STEP. 7 Setup
Product language
Select the languages you want
= == EE——
Garman
[¥] English
[l French
[] spanish
[C1talian
< Back ]L Mext = ] [ Cancel
1
12
13 - Select the product languages (at least ‘English’ AND ‘German’ are required !)
14 - Click on Button ‘Next’ to continue
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{5 STEP. 7 Setup

Transfer License'Keys.
Please select whether you
transferred,

Required License Keys:
STEP 7-BASIS V5.3

() ¥es, transfer should take place during the installation
() Mo, transfer License Keys later

TransFerring license Keys:

Erom w Ta |Q cl

[ < Back ][ Mext = ] [ Cancel

- Select, if you want to transfer the required license key during the installation (an
authorization disk with a valid license is required for this).
- Click on Button ‘Next’ to continue

S.STEP 7 Setup

Ready to Install the Progran

The wizard is ready to begin:

Click Install to begin the installation,

I vou wank ko review ar change any of vour installation settings, click Back. Click Cancel to
exit the wizard.

Customer Information
User Mame: 115 IM MAS PE
Qrganization: Siemens &G

Install to: C:\Program Files\Siemens|Step?, =
The Following languages will be installed:

Deutsch

English

Transfer License Keys:

This procedure takes place during setup bt
< Back ][ Install ] [ Cancel
- Click on Button ‘Install’ to continue

{5 STEP. 7 Setup

Installing STEP 7
The program Features you s i
_ = - TTEE—S—
Flease wait while the Installshield Wizard installs STEP 7. This may take
several minutes,

Status:

Copying new files

[ ]

< Back Mext =

11

12
13

(the installation continues automatically. This part of the installation will take quite a time with
various progress displays depending on the products you selected for installation).)
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{15 STEP. 7 Setup

the wizard,

\

SIEMENS

STEP 7 Setup is complete

Setup has installed STEP 7 successfully, Click "Finish" to exit

It is impartant that you read the notes on Windows 2P user
tights in the file readme wri, in order to quarantee
error-free operation,

< Back Cancel

IMAC L Automation

Installation of Applications

- Click on Button

Memory Card Parameter Assignment

i~ Interface

& None

" htermial prografirning device interface

" Ewtemnal prommer At the connection

‘Finish’ to complete Step 7 setup

X

Cancel I Help J

- Select a programming device (if you have one) or leave setting at ‘none’

- Click on Button

Install/Remowve Interfaces

Selection:

Module I
CPEETT [PlughPlay)
CPE512 [PlhughFlay]
CPEETT [PlughFlay]

0 Ind. Ethernet
PC Adapter
TCRAP

Inztall -->

LOKy

Installed:

Module ]
B0 150 Ind. Ethemet - Intel[F) PROAD00CT ...
TCPAP -» Intel[R] PROAD00CT M.

TCP/P - Ndisw'anlp

< |

|

[ Dizplay modules ready for operation only

Claze

|SIE MEMNS Industnal Ethemet IS0 Protocaol for Your MDIS Metvworkboard [CF)

]

Help

- Check, if the installation of interfaces is correct. Install missing devices, if applicable

- Click on Button

‘Close’
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Set PG/PC Interface |z|

Accesz Path |

Access Paint of the Application:

[Standard for STEP 7)

tl

Interface Parameter Aszignment sed:

!ISD Ind. Ethernet -» IntelR] PRO/1000 CT Properties... I
] Diagnostics... !

TCPAP -» Mdigwanlp 28|
< I | >

[dasigning Parameters to Your MDIS CF
with the 150 Protocol)

i~ Interfaces 1

‘ Add/Remove: Select. . I
oo | _ito_|

- Select Interface to be used (Add, if it is missing)
- Check, if the installation of the selected PG/PC interface is correct (buttons
properties / diagnostics). Then Click on Button ‘OK’

Setup haz successfully inzstalled and configured the software on
your computer.

“You zan find information in the "readme" file.

The computer has to be restarted. Setup can restart the
computer haw, or you can do it yourself |ater.

& Hes restart the computer now

2| I A 7 Nao, the computer will be restarted later.
SIEMENS i
Setup iz finished.
< Back ! Finizh | Eancel !
- Click on Button ‘Finish’ to close the installation and reboot your computer
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752 Language Setting of ‘Simatic Manager’

- Double-click on the ‘Simatic Manager’ icon on your desktop:

SIMATIC
Manager

- The Simatic Manager window will open :

File PLC Wiew Options “Window Help

D=l Bl7| v @ »|

Press F1 to get Help. A

- Click on ‘Options = Customize’
- Select the ‘Language’ tab
- Change the ‘Mnemonics’ language to ‘German ! (Required for import of S7-Code)

x
Language | 'Generall Wiel I Eolumnsl Message numbersl »’-‘«rchivingl
—Mational Language——————— M nemanic:
|english Example 1 Erample 2
|deutsch | (¢ Geman UELD S AdD
" English A0 5040
Cancel | Help |
Hint :

If you usually will use English mnemonics, it is possible to change this setting temporarily
(the ‘German’ setting is required for compiling the IMAC L S7 Source files only).
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8 IMAC L Software

IMAC L basically consists of AlphaVision software plus additional software parts and
settings. A full installation of AlphaVision from AlphaVision install files is not recommended.
The integration of IMAC L specific files, folders and settings is complex and prone to fail for
non-experts. This type of installation is reserved for the IMAC L development team and not
suitable for IMAC L users. Usually this is only required, if a new version of AlphaVision
software is to be used for IMAC L.

Therefore the preferred method for Installing IMAC L is to simply unpack one of the Template
project files delivered on the ‘IMAC L Engineering System Install CD’. These Zip file contain
a complete set of AlphaVision software with all required IMAC L add-ons and configurations
and some example measuring points.

The following IMAC L Template files are available:

o IMAC_L Eng PC.zip (All files for IMAC L Engineering and OS operation)
o IMAC_L_OS PC.zip (All files for IMAC L OS operation only)

To use AlphaVision, two small additional software packages have to be installed on each OS
or Engineering PC:

o Microsoft ‘Visual C++ 2008 Redistributable’ (for AlphaVision V10.x and higher)
o WibuKey Software (to enable WibuKey USB License Keys)

The following three subsections describe the unpacking of the IMAC L Template project and
the installation of these two additional software packages.

The last subsection describes the Installation of the WibuKey USB hardware license key.

Attention :if you have an existing version of the AlphaVision package on your PC, it is highly
recommended to save any existing data in the ‘C:\vision’ path before starting this
installation. This installation procedure will generously replace / remove any
existing files without further questioning ! It is generally required to remove older
versions of AlphaVision completely (e.g. by renaming the directory C:\vision\)
before installing a newer package !
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8.1 Unpacking the ‘IMAC L Template project’

The template files delivered for IMAC L will be packed in a zip-file, that is located in the sub-
folder IMAC_Templates’ of the IMAC L Engineering System Install CD.

Necessary Preconditions:

If you have already installed AlphaVision in path ‘C:\vision’, create a backup copy and
rename or delete this directory. The directory ‘C:\vision’ may not exist, before you continue to
install IMAC L. If you cannot rename or delete the ‘C:\vision’ directory because Windows
refuses to allow, please reboot the PC to unload any IMAC L software (e.g. DLL) from the PC
memory and then retry.

To install the template project :

- Insert the IMAC L Engineering System Install CD’ into the CD-ROM drive

- Click on ‘Start > Programs - Accessories - Windows Explorer’

- Navigate to your CD-Rom drive

- Right-Click on: DAIMAC_Templates\IMAC_L_Eng PC.zip  (Engineering PC)
- or: DANMAC_Templates\ IMAC_L_OS_PC.zip (OS PC)

- (replace ‘D’ with the drive letter of your CD-ROM drive).

- Clickon ‘7-Zip > Extract Files’ in the context menu that has appeared

The 7-Zip ‘extract’ window will open :

Earact x|
Extract to:
[E= =
rPathmode —— r— Overwrite mode
£ Full pathnames & sk before ovenwite
& Current pathnames " Dvenwrite without prompt
' Na pathnames " Skip existing files

 Auto rename

7 Auto rename existing flez

~Pazzword

[ Show Password

Ok I Cancel | Help |

- Select the ‘extract options’ as shown above.

- Specify your drive  ‘C:\’ as the target directory (Zip file contains folder information)

- Click on ‘OK’ to start unpacking

- If 7-Zip should ask, if some already existing files are to be replaced, terminate the
extract procedure (close window). Go back to square 1 (see above, ‘Preconditions’).

- Close the 7-Zip window after completion of the extrat procedure.

- Check, if a directory ‘C:\vision’ has been created and contains subdirectories as
depicted below (the name of the second directory * IMAC L _Temlate ... " may vary
depending on the version being used; if you have unpacked the ‘OS’ version of the
template files, some directories will be missing).
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8.2 Installing Microsoft ‘Visual C++ 2008 Redistributable’ Software

- Click on ‘Start > Run’

The following dialogue will appear :

i Type the name of a program, folder, document, ar
B Internet resource, and Windows will open it Faor you,

W isualC Runtime!viredist 66 en.exe LT

[ Ok H Zancel H Browse. ., ]

- Enter ‘D:\VisualC_Runtime\vcredist x86 en.exe’

10
1
12
13
14
15

(replace ‘D’ with the drive letter of your CD-ROM drive)

- Click on ‘OK’

If the following dialogue should appear, the required package is already installed (from a
previous installation). In this case click on ‘Cancel’ and skip the installation of this software

package.

#5 Microsoft Visual C++ 2008 Redistributable Setup 3l=

Maintenance mode

Select one of the options below:

O Repair
Repair Microsoft Visual C++ 2008 Redistributable to its original state.

() Uninstall

Uninskall Microsoft Yisual C++ 2008 Redistributable From this computer,

Cancel
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2 If the required software package is not yet installed), the following dialogue will appear:

icrosoft Visual C++ 2008 Redistributable Setup

Welcome to Microsoft Yisual C++ 2008
Redistribut able Setup

This wizard will guide you through the installation process.

Mext = ][ Cancel

4
5 - Click on ‘Next’
6
7

The following dialogue will appear :

i Microsoft Visual C++ 2008 Redistributable Setup

License Terms

Be sure to carefully read and understand all the rights and restrictions described in the
license terms. You musk accept the license terms before you can install the software,

MICROSOFT SOFTWARE LICENSE TERMS ~

MICROSOFT WISUAL C++ 2008 RUNTIME LIBRARIES (%86, IA64 AND X64), SERVICE

PACK 1

These license terms are an agreement between Microsoft Corporation {or based on

where vou live, one of its affiliates) and vou, Please read them. Thev apply to the

software named above, which includes the media on which you received it, if any. The

terms also apply ko any Microsaft

» Updates, w
A

Press the Page Down key to see more text.

[¥]1 have read and accept the license terms.

< Back ][ Install = ][ Cancel

10 - Tick (check) the checkmark ‘| have read and accepted ...’
11 - Click on ‘Install’.
12
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]
2 Installation progress is being displayed ...

icrosoft Visual C++ 2008 Redistributable Setup

Installing components

The items you selected are being installad.

Installation Prograss:

Copying new files
Filz: mfc90u.dll, Directary:

CAINDOWSiwinsxsx86_Microsoft, w90, MFC_1fc8b3b9aleldesh_9.0.30729. 1 x-ww 4.,
Sige: 3763672

Cancel |

4
5 Instalation is completed.

icrosoft Visual C++ 2008 Redistributable Setup

Setup Complete

Microsoft Yisual C++ 2008 Redistributable has been successfully installed.

It is highly recommended that yvou download and install the latest service packs and
security updates For this product,

For more information, visit the Following 'Web site:

Product Support Center

7
8 - Click on ‘Finish’
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8.3 Installing ‘WibuKey’ Software

Although this software is only required to run WibuKey encrypted hardlock dongles, it should
be installed even if in case that the use of software licenses is planned. This will ease later

upgrades and service.

To install the driver software package:

Click on ‘Start > Run’

The following dialogue will appear :

Type the name of a program, Folder, document, or
Internet resource, and Windows will open it For vou.

R

1 iibukes: Runkime [ LT |

[ (o4 J [ Cancel ] [ Browse, .. ]
- Enter ‘D:\WibuKey\WkRuntime.exe’
(replace ‘D’ with the drive letter of your CD-ROM drive)
- Click on ‘OK’

The following dialogue will appear :

‘Welcome to the WIBL-KEY Software Setup program.
Thiz program will install 'WIBU-KEY Software on your
= computer.

It iz strongly recommended that you exit all Windows programs [and the
control panel] befare running this Setup program,

Click »Cancels to quit Setup and then clage any programs you have
Tunning.
Click zMests to continue with the Setup program.

Wersion 5.00

Cancel

Click on
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The following dialogue will appear :

™ French

¥ Geman
I ltalian

™ Hungatian
I~ Japaness
I Portuguese
I~ Spanish

< Back | Mext » l Cancel |

- Tick (check) the Language ‘German’
- Click on ‘Next’

The following dialogue will appear :

Setup will install the 'WIBU-KEY Tools in the following folder.
Tainstall to this folder, click sMests.

Tainstall to a diferent folder, click »Browses and select
another folder.

*Y'ou can chooze not to install the WIBU-KEY tools by clicking
sCancels to exit Setup,

1~ Destination Folder

| lE:\Program Files"Ww/IBLIKEY Browse... |!

Cancel |

< Back |

- Click on ‘Next’

The following dialogue will appear :

? | The specified folder does naot exist.

Should Setup create the Folder?

Yes Mo l

- Click on ‘Yes
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The following dialogue will appear :

Select the WIBU-KEY components you like to install

v 37 R Wk et AVKUAN Network Server
[ Irstall as NT service with autostart

I wikMet Metwork Server for Movel Nebware

¥ WWkLAN Ax kM et Metwork Maonitor (32 bit)

etk b t]

Once you have selected the components you wizh to install,
press the sMests button to complete the installation.

< Back | Mext » I Cancel |

- Tick (check) choices as depicted above
- Click on ‘Next’

The following dialogue will appear :

If you press sMests the following tazks will be performed:

Operating syzstem: Windows XP
Source path: CADOCUME ~1\Master\LOCALS ~15T empiWESED

Selected languages:
English
German

The following components will be installed:
I BL-KEY driver files

wBL-KEY COM contral
WIBL-5YSTEMS Shell Extension

I BL-KE'Y netwark server

WIBL-KEY ook

< Back |" Cancel

- Click on ‘Next’

The following dialogue will appear :

If you press sMests the following tasks will be perfarmed:

German

&

The following components will be installed:
W BL-KEY driver files

wIBL-KEY COM contral
'WIBL-SYSTEMS Shell Extension
WIBL-KEY netwark server

i BL-KEY tools

Copying filez ... done.

Werifying language modules ...

Installing files ... done.

Werifying installed language modules ... done.
Storing uninstall information ... done.
Creating shortcuts ... done.

Transfering settings ...

=

| [dest I
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The following dialogue will appear :

;=1 WIBU-KEY Setup

If you press sMests the following tasks will be perfarmed:

&

The following components will be installed:
W BL-KEY driver files

WIBL-KEY COM contral
WIBL-5YSTEMS Shell Extenzion
'wIBL-KEY netwark server

WIBL-KEY tooks

Copying filez ... done.

Werifying language modules ...

Installing files ... done.

Werifying installed language modules ... done.
Storing uninstall information ... done.
Creating shortcuts ... done,

Transfering settings ... done.

Sl

Cancel

< Back |

- Click on ‘Next’

The following dialogue will appear :

WIBU-KEY Setup

WIBL-KEY Software Setup is complete.

Setup can launch the Readme help file with the latest product
informations.

W “fes, | want to view the Readme text now.

Click. 2Finizhs to complate Setup,

- Click on ‘Finish’
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8.4 Installing AlphaVision ‘Engineering’ / ‘Runtime’ Licenses

For running IMAC L, an AlphaVision license key is required. The ‘IMAC L Engineering
System Install CD’ does not contain license keys for AlphaVision. You will have to buy one
AlphaVision runtime license for every OS of a Project.

There are two basic versions of this license key:

0 Runtime License (required for Operator Stations)
o Engineering & Runtime License (required for Engineering PCs)

For internal use in Siemens Marine Engineering a master license key ‘Engineering &
Runtime’ is available on request. This master license may be used within Siemens Marine
Engineering and must not be delivered to customers. For use in other departments or
companies or for sale to customers (separate or as part of your project) you will not be
allowed to use this master engineering license. In this case you will have to buy your own
license(s) as required.

There are basically two ways to install such a AlphaVision License key:

o WibuKey Hardware USB Dongle (PC-HW-independent, recommended)
o Software Key (PC-HW-dependent, not recommended)

Both methods of license key installation are described below. The WibuKey USB Dongle
licenses do not depend on the PC Hardware they are used on (are interchangeable between
PCs). The Software Keys are specific for one PC hardware and will become invalid e.g. in
case of PC hardware replacement. In such a case a new key would have to be created.
Therefore the Software-Key option should only be used as a backup in case there are
difficulties with USB or mechanical installation of the hardware dongle.

If no or a temporary license is installed, a warning window will pop up during the start of
AlphaVision applications, that will indicate, when the application in question will terminate
itself automatically :

Warning: Dema wersion of limited licence! !
This application will close at: 03 March 2006

0] 4 | Cancel |

Important : Please do not leave any ship in this condition ! Later on, the respective
application will terminate itself without any further warning after reaching the
indicated time !

© Siemens AG 2009, All Rights reserved ¢ | IS MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D67 / 97

IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



o b~ W

~

10

1
12
13
14

15
16
17
18
19
20
21

2

24

25
26
27
28
29
30
31
32
33

34
35

36

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Installation of IMAC L Software
8.4.1 Installing the AlphaVision License File ‘VISION.LIC’

AlphaVision always requires a license file: ‘C:\vision\bin\VISION.LIC’
The templates installed above do not contain this file, as it is a part of the license you buy.

The following special rules apply to this very special file:

o There are different versions of the VISION.LIC file, which can only be distinguished
by their file date and time.

a The license key used (HW- or SW-key) and this VISION.LIC file have to match. If they
do not match, the license will not be recognized.

o Changing the VISION.LIC file’s contents or it's date or time will render it useless.
Therefore the VISION.LIC file can only be E-Mailed, if packed in a ZIP file. Burning it
directly to a CD or E-Mailing it directly (not in a ZIP file) will render it useless, as the
file attributes will change..

You will receive the required VISION.LIC file in a ZIP file with your license purchase. If you
should have received an ‘Engineering Master License’ key for your engineering work, please
ask your IMAC L support partner in the Siemens Marine Engineering department for the
required file.

To install it, simply open the ZIP file and unpack this file to it's required location in the
‘C:\vision\binV’ directory.

8.4.2 Installing ‘WibuKey’ Hardware USB License Key for AlphaVision

The IMAC L license keys are preferably stored in encrypted WibuKey hardlocks.
If you should use an IMAC L software key instead, this section has to be skipped. In this
case continue with the next section.

To install such a WibuKey hardlock, the WibuKey driver software has to be installed first (see
above: - Installing ‘WibuKey’ Software, Page 63). Then connect the USB key to a free USB
port of the PC.

The following dialogue will appear :
Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard
windows will zearch for curent and updated software by

lnoking on your computer, on the hardware installation CD, or on
‘wheb gite [with your permiszion).

Can Windows connect o Windows Update to search for
software?

(O es, this ime anly
(0 es, now and every time | connect a device
() Mo, nat this time

Click Next to continue.

Cancel

- Select the radio button ‘No, not this time’

© Siemens AG 2009, All Rights reserved ¢ | IS MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D68 / 97

IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



AW N -

1"
12

13
14
15
16
17
18
19
20
21
22
23
24

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Installation of IMAC L Software
- Click on ‘Next’

The following dialogue will appear :

Found New Hardware Wizard

Thiz wizard helps vou install software for:

‘i BL-B 0K

) If your hardware came with an installation CD
g2 or Hloppy disk. insert it now.

What do you want the wizard to do?

% Install the software automaticaly [Fecommended)
(2 Install from a list or specific location [Advanced)

Click Mext to continue.

l < Back " Mext > ]I Cancel ]

The following dialogue will appear :

Select the radio button ‘Install ... automatically ...’
Click on ‘Next’

Found New Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard has finizhed instaling the software for:

_\> WIBLI-BOXA

Click Finish to close the wizard.

Click on ‘Finish’

Recommendation :

For onboard installation of such a Hardware ‘WibuKey’ USB License Key it is recommended
to use a short (~1m) USB extension cord to connect the USB key Use a cable strap to
mechanically attach the key to a console rack or similar. This has several advantages:

The PC and key are protected against damage. If the is key directly connected, it will
stick out from the PC case and will be vulnerable to mechanical mistreatment.

The key will be protected against loosening / loss (e.g. due to vibration).

The key will not get lost, if the PC is being replaced (sparepart) or sent for repair

The location where the key is attached may hold a label indicating it's purpose / data.
Possible theft can be avoided (danger of mixing up with a stylish USB memory stick)

© Siemens AG 2009, All Rights reserved ¢ | IS MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D69 / 97

IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



© 0 N O O b~ W

11
12

13

14
15
16
17
18
19

20

21
22
23
24
25
26
27
28

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Installation of IMAC L Software
8.4.3 Installing a Software License Key for AlphaVision

Installing a software license is not the preferred method for IMAC L AlphaVision licensing. If
you should have decided to install the recommended WibuKey encrypted USB hardware
dongles, this section has to be skipped. As this section is quite lengthy, you may in this case
be happy about your choice ©.

For AlphaVision there are two different methods used for installing software licenses. The
‘old’ method is used for versions originating from November 2005 and before. The ‘new’
method is used for AlphaVision versions originating from December 2005 or later. These are
not alternative methods. The right method for the respective version has to be applied.

Old Licenses for AlphaVision Versions (until November 2005, only Windows 2000)

The old method is done by just copying a valid license file ‘Vision.lic’ to the ‘C:\vision\bin’
directory of each OS. Please observe, that the license file may not be modified in any
whatsoever way - or it will not work. This rule applies to the file's date & time stamp as well.
Therefore the ‘Vision.lic’ file has to be packed (e.g. using WinZip) in order to be e-Mailed or
archived to a CD.

New Licenses for AlphaVision Versions (from December 2005)

The general procedure for this new style of licenses is as follows:

Install the necessary Installation Applications (first time only).

Install the ‘Vision.lic’ file that has been bought from Alpha-Bit.

Generate a ‘Hardware Key’ using the AbLiclnstaller application.

Request the ‘Software Key’ for this OS from Alpha-Bit (either by e-Mail or via the
Alpha-Bit Web interface: http://www.alpha-bit.de/download/HWKey/index.php ).

Install the ‘Software Key’ using the AbSWKeylnstaller application.

Check the successful installation of the key.

BN =

oo
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These procedure steps for installation of licenses in detail are as follows:

1. Install the necessary installation applications (first time only) :
- Insert the IMAC L Engineering System Install CD’ into the CD-ROM drive.

- Click on ‘Start > Run’
- Enter ‘D:\Vision\Licencelnstaller.zip’

(replace D with the drive letter of your CD-ROM drive).
- Click on ‘oK

- In WinZip click on the ‘Extract’ button and unpack all three files to the ‘C:\Vision\bin’
directory of the OS that is to receive the license.
- Close WinZip.

2. Install the ‘Vision.lic’ file that has been bought from Alpha-Bit :
- Open the ZIP-file that contains the require license
- In WinZip click on the ‘Extract’ button and unpack the ‘Vision.lic’ file to the
‘C:\Vision\bin’ directory of the OS that is to receive the license.

- Close WinZip.

3. Generate a ‘Hardware Key’ using the AbLiclnstaller application :
- Click on ‘Start > Run’
- Enter ‘C:\vision\bin\AbLiclnstaller.exe’.
- Click on ‘OK’
- The AbLiclnstaller Application opens:

il Ablicnstaller i X

Source lic-file: IE Kvision' MbinkWISIOM LIC lj

Install

Hardware key: |

Copyto clipbeard

- Take care, that the first input Iline in this application points to
‘C:\vision\bin\VISION.LIC’. If not, use the browse button right of this line to point to the
correct file.

- Then click on the ‘Install’ button. The ‘Hardware Key’ line will show the ‘Hardware

Key' generated by the AbLiclnstaller. Observe, that the lower text field in the
application reports successful generating of the ‘Hardware Key'.

i abLicInstaller X x|
Source lic-file: IC'\vismn\hin\VlSIDN LiC i
Hardware key: |E10i]'h‘3‘:' BB18DFD 371 DEAN2ZE5EF 3456F BEBF GFEFEC7A0E03850 43841 6ECTBEFBAT

Copy to clipboard
The installation was successhul A hardware Key was generated

- Click on the ‘Copy to Clippord’ button.

- Close the AbLiclnstaller Window.

- Clickon ‘Start > Programs - Accessories > Notepad
- In the Notepad application click on ‘Edit > Paste’:
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1ol
File Edit Format Help

H oz

Bavens 2=
Save in: |ahm j &= [ '

In the Notepad application click on ‘File > Save As’:

2 help
IZ] readme. bzt

File name:

Save I
Cancel |

v

| Saveas type: IText Documents [*kxt]

[EAWERNEY

Encoding: |ANS|

Enter a name for the key file (e.g. ‘HardwareKeyOS1.itxt’) and point to a convenient
location to transfer this key to Alpha-Bit (e.g. USB Stick or floppy disk).

Click on ‘OK’

Close the Notepad application.

Transfer the text file containing the ‘Hardware Key' to a computer where you have
access to e-Mail or the internet.

4. Request the ‘Software Key’ for this OS from Alpha-Bit :

Transfer the Generated ‘Hardware Key’ to Alpha-Bit. This can be done either via via
the Alpha-Bit Web-Interface or e-Mail (or even by telephone). Use ‘Copy / Paste’
while transferring the key to an e-Mail or to the web interface in order to avoid typing
errors. For requesting this key from Alpha-Bit you are required to present your
License number, which is to be found on the delivery note you have received
together with your license delivery from Alpha-Bit.

Wait to receive the required ‘Software Key'. In the Web-Interface you will
immediately receive this key, if your ‘License Number’ and your ‘Hardware Key’ are
OK.

Store the received ‘Software Key’ in a text file (e.g. ‘SoftwareKeyOS1.txt’) using the
Notepad application again.

Copy this text file containing the ‘Software Key’ to a USB stick or floppy disk

Transfer the text file containing the ‘Software Key’ to the OS where it is required

5. Install the ‘Software Key’ using the AbSWKeylnstaller application :

Click on ‘Start > Run’
Enter ‘C:\vision\bin\AbSWKeyInstaller.exe’'.
Click on ‘OK’

The AbSWKeyInstaller Application opens:

i AbSWKeyInstaller x|

Software key

This i not &

alid software Key

© Siemens AG 2009, All Rights reserved ¢ | IS MAS PE 2 + Uwe Hottendorff + SD 2009-06-25 13 ¢ PD 2009-06-25 09:07 * Doc.-No. E10231-Y1009-U305-D72 / 97

IMAC L Automation ¢ I:\projekte\IMAC_55\U=Aut\1=LeitSys\+L14=Para&Structure\inst_Engineering_PC\I55L_Inst_Engineering_PC_RevD_20090625.doc ¢ Release D



© 0O N o g »h WO N -

N D NN N N DN NN NN 2 A A A a a a a a o
© 0 N O OO b WO N 2 O © 0N O O » W N =~ O

Marine Engineering

IMAC L Engineering PC IMAC L Automation
Installation Procedure Installation of IMAC L Software
- Clickon ‘Start > Programs - Accessories - Notepad

- In the Notepad application click on ‘File - Open’.

- Point to the location of the text file containing the ‘Software Key'.

- Click on ‘Open’

- Click on ‘Edit Select All

- Click on ‘Edit Copy’

- Close the Notepad application.

- Click into the ‘Software key’ input field of the ‘AbSWKeylnstaller’ application, so that
the input cursor shows up in this field.

- Press ‘Ctrl-V’ to paste the key into this field.

- Then click on the ‘Install’ button of the AbSWKeylnstaller application. Observe, that
the lower text field in the application reports successful installation of the key.

- Close the AbSWKeyInstaller Window.

6. Check the successful installation of the key :

- Run the IMAC L application on the OS as usual (e.g. Double-Click on the Run_IMAC
icon on the desktop of the OS or better reboot the OS, if the start of IMAC L is
automatic as it should be for an OS).

- Observe, that the ‘Demo Version or limited licence’ popup window (indicating, that a
license is missing) does not show up any more for any application.

Hint :Usually the time delay for the application to terminate is 30 minutes if no license at all
has been installed. This time will be extended to 30 days, if the ‘Hardware Key’ has been
generated successfully (see step 3 of the above procedure). If you leave a ship with such a
30 days license, you have to return to this ship within this time to install the valid unlimited
license, or the respective application will terminate (fail to function) after the time has expired!
After the 30 days have expired once, the applications will only work for 30 minutes before
they terminate ! Please check the validity of installed licenses (see Checking the validity of
AlphaVision License Keys—>, page 74) before leaving a ship.
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844 Checking the validity of AlphaVision License Keys

It is important to check, if an OS on board of a ship has a valid AlphaVision license key, that
does not expire after 30 minutes or 30 days (see previous sections). Leaving a ship with a
time-limited license will inevitably cause a service engineer to be called to fix this.

To check the validity of licenses without waiting for 30 days, AlphaVision has a built-in tool to
retrieve information about the installed licenses:

- Click on ‘Start > Run’

The following dialogue will appear :

Run

Type the name of a program, Folder, document, or
Internet resource, and Windows will open it For wou,

Open: C':;I,vision'l,bin'l,P.iJGe't'LicInF'o.exe w
[ [a]4 l [ Cancel ] [ Browse. ..
- Enter ‘C:\vision\bin\AbGetLicInfo.exe’
- Click on ‘OK’

A DOS Text window will appear. The first block of the displayed information will show, if a
valid key is installed. If a valid USB WibuKey dongle is installed, the top of the display will
look like this (license file information may be different):
_D x]
4]

Is dongle mounted 7 ¥
FindDongleMatchingToLicFile —> @ <WK_ERE_HNONE>

oo~ -Jof a3~ Jo oo~ Jof~of-Jof-oE - JoE o3k -Jof-of-Jof-Tof~3E-JoE-of 3ok - Jof-of-JoE-Jof~3E- o -Jof 3ok Jof-of- Je-Jof -3 oo

Licence—file information:

Licensee = SAG_I&S-IP-MAS-LCHM_Projektierungstools
Licenser = alpha—hit GmbH. Erlangen

License ID = B611443758

License Date = 20878684

This is the only acceptable output here. Especially the line:
“Valid SW-key or dongle installed ? Y”
is important! If this line is missing, you have to assume, that no valid license is installed.

If you are in doubt of the validity of a AlphaVision license, you may copy and paste the
contents of the AbGetLiclnfo.exe window to a text file and mail it to your IMAC L support
partner in the Siemens Marine Engineering department for verification. To copy this text:
Point your mouse at the header (caption bar) of the Window

Right-Click on ‘Edit > Select All

Right-Click on ‘Edit - Copy’.

Paste to Notepad / Editor and save as a text file
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Output examples for a missing or temporary license:

If no license or only a thirty days temporary license is installed, the top of the display will
look like this (no WibuKey dongle & driver installed, License File ‘C:\vision\bin\VISION.LIC’ is
present) :

c on’bin’ AbGetLicInfo.exe
AhGetLicInfo

Licence file found?
;Ualid Sl-key or dongle installed"™ ? WIBU-Runtime HOT found?

If only a thirty days license is installed, the output will contain a section like this (scroll down
to middle of output):

e Loy wision' bin' AbGetLicInfo.exe

HW—-SW-key information
"38—day key insztalled™ 7 ¥
"EW-key installed" 7 N

Ualue 1 = BE1742B5EYCE

Ualue 2 = BE5B56CHABEAR

38—day countdown = 288986161152217685

3B8—day key valid 7 ¥

HW-key = BBAB31E1184BD?FB235728F3D6F26786DD1 PS5 FECFAFG2784DA32A263D1ADE3 7Y

Observe the following two lines

“30-day key installed ? Y”

“SW-key installed ? N”
These two entries clearly show, that this license is temporary for 30 days and will expire at
any time within the next 30 days.

If a license expires, while the IMAC L software is running, the applications will terminate
without a pre-warning. Any further start will then be temporary for 30 minutes (the 30 days
cannot be re-activated again) !
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8.5 Creating Desktop Shortcuts

8.5.1 Desktop Shortcuts for IMAC L Engineering PC

For an Engineering PC it is useful to have a row of desktop shortcuts for IMAC L, that
basically represents the sequence of engineering in order to create an IMAC L project :

AvEdit Copy _DBF Pri Copy OISO 1 : Run_IMaC
Manager

- Microsoft Excel (Icon has been created during MS Office setup).
- AVET (point to C:\vision\bin\AvET.exe)

- Copy_DBF (point to C:\vision\PrjAvEt\Copy_DBF.cmd)

- Pmu (point to C:\vision\bin\Pmu.exe)

- Copy_DISDO (point to C:\vision\PrjAvEt\Copy_DISDO.cmd)

- Simatic Manager  (Icon has been created during Simatic Manager setup).
- Run_IMAC (point to C:\vision\PrjAvEt\Run_IMAC.cmd)

- Run_IMAC_EAS (point to C:\vision\PrjAvEt\ Run_IMAC _EAS.cmd)
8.5.2 Desktop Shortcuts for IMAC L OSs
An IMAC L OS requires only one of the two last Icons:

- Run_IMAC (point to C:\vision\PrjAvEt\Run_IMAC.cmd)
- Run_IMAC_EAS (point to C:\vision\PrjAvEt\ Run_IMAC_EAS.cmd)

The default choice is ‘Run_IMAC’. Only if the system has an Extended Alarm System (EAS)
attached to it, OS1 will require ‘Run_IMAC_EAS’ instead of ‘Run_IMAC’.
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8.6 OS specific IMAC L Settings

For an IMAC L Engineering PC that will never run the AlphaVision runtime (engineering
only), this ‘OS specific IMAC L Settings’ section may be completely skipped.

PC-specific settings (in order to distinguish one PC from the others) include the already
completed settings in the Windows XP operating system:

o IP-address (see above in this document - ‘IP Address’ Setting, page 22)

0 Network Name (see above in this document >‘Computer Name’ and ‘Workgroup

Name’ Settings, page 30)

If a PC is to be used as an IMAC L OS (i.e. AlphaVision Runtime will be started), additional
settings are required for each possible OS. The following rules for IMAC L OS numbering
apply:

- IMAC L OS numbering starts with ‘1’. The permitted range is ‘1°...’8".

- Gaps in OS numbering should be avoided (are irritating)

- 0OS1 has some special functions (e.g. drives the EAS system, if required)

- More than 8 OSs are not possible.

8.6.1 Setting the OS-Number for Alpha-Vision

IMAC L OSs require the setting of the logical OS-number for Alpha-Vision. This is required to
be an individual setting for each OS. Please repeat for each individual OS:

- Clickon ‘Start > Run’
- Enter ‘C:\vision\bin\cfg.exe’
- Click on ‘OK’
- In the ‘Cfg’ editor click on File > Open
- Point to the configuration file C:\vision\bin\IMAC_L.cfg
- Click on ‘OK’
File Help
Startdisplay l Startvalues I System I
Control Acocess | Diefault | Display
Logout
Minutes: |U
Seconds: |U
05 -1d: |1U1I
il
0K || el || e |

- Modify the ‘OS-Id’ field to “10x’ (where x is the OS-number, see above)
(do not modify any of the other setting)
- In the ‘Cfg’ editor click on File > Save
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8.6.2 Modifying the ,O0S Watchdog Settings’

IMAC L OSs require some OS-specific OS Watchdog Settings. The file to be modified on
each OS is:

‘C:\vision\bin\Vision200.ini’

These OS Watchdog settings are different for each OS. Please repeat all of the following
settings for each individual OS:

- Clickon ‘Start > Programs - Accessories > Windows Explorer’
- Navigate to the ‘C:\vision\bin\" directory
- Double-Click on ‘C:\vision\bin\Vision200.in/’

An editor window will open.

Scroll down and find the [watchdog] section:

I Vision2000.ini - Notepad A==
File Edit Format “iew Help

[watchdog] B
File=c:ivwwisionhbinswdog, txt

TouchTime=5000
;wwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwww

; 0S-specific application watchdog settings

; 05-Specific Maming of wariable @ wDGPRCOx (where x = OS-Number) !
Prcs=wDGPRZOL, 20

; 05-Specific Maming of wariable @ wDGUDPOx (where x = OS-Number) !

Udp2 av=wDGUDPOL, 20

i 0S-Specific Maming of wariable @ wWDGEASOx (where x = O0S-Number) !
Av2eofTEas=WDGEASOL, 20

EIRCR R T T PR T IR P T P T T T P A T T T A T T R T TR T A T R T T R R R T TR AR TR R
L]

b
- Adjust the ‘Prcs=WDGPRCO0x’ parameter: 2>  x=0S-number!
- Adjust the ‘Upd2Av=WDGUDPOX’ parameter: 2>  x=0S-number!
- Adjust the ‘Av2SoftEas=WDGEASOx’ parameter: >  x = 0S-number !

- Click on File > Save
- Close the Editor Window

The example depicted above shows the default settings (for OS1). For OS2 the three
parameter values would be: ‘WDGPRC02’ / ‘WDGUDPO02’ / ‘WDGEAS02'.

The parameters modified here adjust the IMAC L ‘Watchdog’ feature. All individual IMAC L
tasks on an OS are monitored by PCU1. In case of a failing task, PCU1 will initiate an
IMAC L alarm. The settings modified here determine for each OS, which watchdog variables
are served by which task. The IMAC L ‘Watchdog’ feature will only work with a correct
assignment as shown above.

Important Warning :
Do not modify / add / remove any other entries in this file. Wrong settings in this file may
render an OS inoperative.
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8.6.3 Modifying the ,UDP Communication Settings’

IMAC L OSs require global UDP Communication Settings in each OS. The file to be modified
on each OS is:

‘C:\vision\bin\Vision200.ini’

The IMAC L UDP communication has to be adjusted to meet the number of OSs / PCUs in a
project. The ‘Vision2000.ini’ parameter ...

‘Stations=" in section ‘[Udp2Av]’

... determines, which communication links will be established and monitored in IMAC L. The
parameter 'Stations' has to contain the logical bus numbers of all OSs and PCUs in a project.
This setting has to fit the project configuration and it has to be identical in all IMAC L OSs
connected to a project configuration. Wrong settings will cause the Ethernet
communication to partly or completely not work.

To check / modify, please repeat all of the following settings for each individual OS:

- Click on ‘Start > Programs - Accessories - Windows Explorer’
- Navigate to the ‘C:\vision\bin\' directory

- Double-Click on ‘C:\vision\bin\Vision200.ini’

- Modify parameter  ‘Stations=" as explained below

- Click on File > Save

- Close the Editor Window

A typical [Udp2Av] section might look like this (entry highlighted in screenshot only):
[ Vision2000.ini - Notepad @@@

File Edit Formatb Wiew Help

.
[udp2av]
PortPlcRead=2000
PortPlcwrite=3000
POrtosread=2200
POrtoswrite=2200
PortDT=2222
Multicast=239.0.1.0
MuTticastos=239%,.0.1.1
BUses=1
Stations=1l, 2, 15,
LiTesignCycle=1500
LifesignTimeout=56000
ReadgueueCycle = 50
LogFilesize=10000000
Consoledutput=1
PacketIdTooLowwaitTime=10000
rRo1Tbacksize=10
MSSync_Prioritys=1

W

The ‘Stations=" parameter has to be adjusted. The following rules apply for this parameter:
o Entries for PCUs are equal to the IMAC L PCU number (‘1° ... ’'8’).
o ‘Entries for OSs have an fixed offset of 100: (OS1 > “101° ... 0S8 - ‘108’)

The example depicted above is set for the use with two PCUs (logical bus numbers 1, 2) and
three OSs (logical bus numbers 101, 102, 103). Add or remove logical bus numbers as
required to meet your current configuration. Leave a space between each entry. Leave entry
15’ untouched (IMAC L internal use).

Important Warning :
Do not modify / add / remove any other entries in this file. Wrong settings in this file may
render an OS inoperative.
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8.6.4 Setting up ,0S Automatic Start’ for IMAC L Software

Section 6.14 (“Automatic Start’ ’) describes how to make programs automatically start during
Windows start.

For an IMAC L OS it is necessary to configure one of the IMAC L start batches for this type
of automatic start.
One of the two following start batches is used to start the IMAC L OS software:
o C:lision\PrjAvEt\Run_IMAC.cmd -  Simple OS
o C:lision\PrjAvEt\ Run_IMAC _EAS.cmd -  only for OS1, if it has to control the
Extended Alarm System (EAS)

For each OS proceed as follows:

- Create the required shortcut according to the a.m. description.
- Reboot the OS to make sure, that automatic start works
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19 Unpacking the IMAC L Simatic S7 Project
2 IMAC L comes with a Simatic S7 project, that has to be used as a starting point for every
3 new IMAC L project. This package contains essential components of IMAC L. This section
4  describes how to unpack this archive.
5
6 Attention!
7 Starting a PLC project from scratch is not intended with IMAC L and there will be no support
8  for such efforts neither are there any descriptions on how to do this. Always use the a.m.
9 template project!
10
11 The Simatic template project for IMAC L is located in the ‘IMAC_L_S7_Project’ directory of
12 your ‘IMAC L Engineering System Install CD’. The File name is ‘IMAC_L_S7_Project.zip’.
13
14 Use the Simatic Managers ‘retrieve’ function to open this project :
15 - Open your Simatic Manager
16 - Click on File >Retrieve
17 - Point to the a.m. IMAC L S7 Project file
18 - Click on ‘Open’
19 - Clickon ‘OK’ :
x|
Lo -] STDATA -
-] S7HSYS
EID s7ifc
- 57K
& S7INF
] S7LIBS _|
l:?.l"D S7MANUAL
-] SPMET
-] S7MGD
-] STHYE
EI% F'I'l:li
- [£3) g | _’l_l
ok I Cancel I Help I
20
21 - Click on ‘OK’ :
x|
@ The retnieved data have been stored in the project
directory 'C:%Program
Filez\SiemenzhStep? S FProjhs Yudp300’,
[T Do not dizplay this mezzage again.
22
23 - Click on ‘OK’ :
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Retrieve (3Z280:754)

The fallowing objects were retrieved:
Projects: 27udp300

Libranes: Mone
Do you want to open these now?

You will have to modify this project including it's hardware configuration and IMAC L related
PLC engineering in order meet your project requirements.

For any further IMAC L related engineering of PLCs please refer to the IMAC L Engineering
Guideline’ (Document No. E10231-Y1009-U304-x).
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10 Backups of IMAC L Software

As with any other software, creating backups of IMAC L software is important to avoid data
loss due to hardware damages, theft or mistakes in the handling of engineering.

Backups should be created regularly (e.g. once a day), while engineering is under way. Any
relevant version of the project (e.g. after an acceptance test, after delivery to the customer,
after a service / update, that has caused a change of software) deserve a backup copy, that
is taken to permanent storage.

Create the updates as described below and store them in a safe place.

Observe standard criteria for long term data archiving like:

o Unambiguous marking of stored software versions (project, version, date, type of
data, instructions for recovery, tools / software required to handle)

Physical long term durability of storage media
Safe physical location for storage media (e.g. protection against theft / fire)

Accessibility - Protection against inadvertent deletion / disposal

O 0 0 DO

Have at least two copies of the same backup - stored in different safe locations.

10.1 Backups of Simatic Software

For creating Backups of Simatic Manager projects simply use the Simatic Manager built-in
archive function:

- In Simatic Manager open the project to archive

- Clickon File = Archive

- Select the project to backup (should already be highlighted)
- Click on ‘OK’

- Select a location and name of the archive

- Click on ‘Save’

- Click on ‘OK’

If the archiving is completed, locate the resulting ZIP file (path & file name you just entered).
Copy and archive as appropriate.
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10.2 Backups of AlphaVision PC Software

On a PC AlphaVision will only install files in the ‘C:\vision\’ directory. All project related data
being engineered according to the ‘IMAC L Engineering Guideline’ will reside in this directory
as well. Therefore, if you stick to the engineering rules, a full backup of this directory and all
it's subdirectories is sufficient to have a full backup of any IMAC PC (OS or Engineering PC).

A file packing tool (e.g. 7-Zip) has to be used to create IMAC L backup archives. The Zip files
as created in this section can be put on a CD/DVD without damage.

Important Hint:
Simple recovery of IMAC L files directly from a CD/DVD (not in a Zip file) will not work! Files

directly copied back from a CD/DVD will have their ‘Read Only’ attribute set. AlphaVision
cannot handle ‘Read Only’ files (this will create error messages, IMAC L will not work, the
IMAC L license files will be permanently damaged after a direct CD/DVD backup).

10.2.1 Create Backups of IMAC L on PCs using ,7-Zip’
To create a backup archive of IMAC L PC software, please proceed as follows:

- Stop all AlphaVision applications (if there should be any running)
- Reboot the PC to unload all software modules (e.g. DLLs) from PC memory.

- Click on ‘Start > Programs - Accessories - Windows Explorer’
- Navigate to the ‘C:\vision\bin\' directory

- Right-Click on the  ‘C:\vision\bin\’ directory. A context menu will open.

- Click on ‘7-Zip > ‘Add to Archive...” in this context menu.

The ‘7-Zip’ window will open:

Add to Archive 3

Archive:
O
Archive format: .Zip b Update made:
Add and replace files b
Compression level: M awirLm bl
) o . Options
Compression method: Deflate M
Dictionary size: 132 KB v | [] Compress shared files
‘wiord size _84 bl Encryption
Solid Black size: Ul
MNumber of CPU threads: 1 | A
Feenter password:
Memary usage for Compressing: 4B
temary usage for Decompressing: 2MB [ Shaw Passward
Split to volumes, bytes: Encryption method: ZipCrypta ~|
; 5
Parameters:
Ok ] [ Cancel ] [ Help

- In the ‘Archive’ field enter a descriptive Name of the Backup to create.
Include the PC (OSx, ES) and Date of backup in this name (see example above).
- Click on ‘OK’
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‘7-Zip’ will create a new archive:

2% Compressing IMAC_L_Backup_OS1_ ... ision_20090618.zip A=

Elapsed time: 00 00:05 Total size: 160 MB
Remaining time: 00.03:32 Speed: 7ER KB/
Files: 5./59329 Processed: I5IE KB
Compression ratio; 1k 4 Compressed size: 1380 KB

wizionbin'
AbCpphdd=DIldil

)

[ Background I [ Fause J [ Cancel l

If the archiving is completed, the resulting ZIP file (with the name you have entered) will be in
the root directory ‘C:\’. Copy and archive this file as appropriate.

10.2.2 Restore Backups of IMAC L on PCs using ,7-Zip’

Preconditions for restoring a backup:

The PC to which the project is restored has to be setup as an AlphaVision PC (OS or
Engineering PC) before you restore a backup copy. This includes all settings and
installations in sections > 6 (Adjustment of Windows Settings) and > 7 (Installation of
Applications) of this document. If this rule is not observed, IMAC L is very likely to fail
partially or completely.

If a backup copy of an IMAC L ‘C:\vision\’ directory is to be restored, please proceed in the
same way as described in Section > 8.1’Unpacking the ‘IMAC L Template project” on page
58). The only difference here is, that you point to the archive file from your backup storage
medium instead of to an IMAC L template file from the ‘IMAC L Engineering System Install
CD'.

Urgently observe, that no ‘C:\vision\’ may exist, before you start a recovery. You have to
stick to the ‘Rename or Delete’ instruction as given in the a.m. description.

Reboot you PC and start your IMAC L applications.

If failure messages occur during start of an IMAC L that was created from an recovery (e.g.
‘not correctly installed’ or ‘missing license’), there are some common causes you might like to
check:

o IMAC L applications are not correctly installed — the a.m. preconditions are not met
(e.g. software packages ‘Microsoft ‘Visual C++ 2008 Redistributable’ or ‘WibuKey’
Software are missing).

a The installed AlphaVision License key is missing (software key or USB WibuKey).

0 The installed AlphaVision License key (software key or USB WibuKey) does not
match the version of the ‘C:\vision\bin\VISION.LIC’ file contained in the recovered
project.

a If you are using a software key, changes in PC hardware will render your old SW key
useless. You have to request a new key in this case (see section - 8.4.3).
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10.2.3 Multiple IMAC L Versions / Projects on one PC

One of the essential restrictions in IMAC L PC software is, that an IMAC L project you are
working with always has to be stored in the ‘C:\vision\’ directory.

This looks as if it is a big restriction, as you seemingly can have only one IMAC L project
installed at a time. This would be bad news for engineers working on more than one IMAC L
project at a time. But there is an easy way out:

Use simple renaming of directories to switch between projects !

The directory of that project you want to work with has to be renamed to be ‘C:\vision\'.
All other IMAC L project directories may exist at the same time on drive ‘C:\’ — just with a
different name. There are just a few simple hints you should observe while using this strategy
to switch projects:

o Terminate all running AlphaVision applications in Windows before renaming.

o If switching between projects using different versions of AlphaVision you have to
reboot the PC to unload all software modules (DLLs) from Windows memory after
such a project switch.

o Each project tree should contain a possibility to uniguely indentify the project it
contains. After some renaming you otherwise will not be able to identify your projects
any more and will start mixing them up. A good possibility is an empty directory in the
project tree, whose name starts with an underscore (* ') character. The name of this
directory identifies your project / version. Due to the underscore, this directory will
always be the first one being displayed in Windows Explorer. This might look like this:

=) vision

42 _IMAC_L_Templabe_200706
-3 bin

-5 EAS_Projekt_IMACL_Standard
BT pri

E_"l prifwET

[F-7) 570emo

F1-7) SoftPlc7Data

&) SoftPlc7SampleHll

The name of this ‘underscore-named’ directory is as well ideal, if a project was in use
and has to be renamed (to switch to another project): Simply ‘Copy and Paste’ the
name of this ‘underscore-named’ directory to rename (in the above example):

‘C:\visionV > ‘C:\_IMAC_L_Template_200706’
The result in this example above will look like this:

E-[3) _IMAC_L_Template 200706

: A IMAC_L_Template_200706
B3 bin
#4) EAS_Projekt IMACL_Standard
EHE) pr
H- priavET
rﬂ_} S7Demo
#-0) SoftPlc7Data
17 SoftPle7sampleHl
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11 Updating IMAC L to a newer AlphaVision

If a new version of the AlphaVision software is released for the use with IMAC L, the
following basic procedure shows, how to update a project to the new version. This procedure
cannot take into account all future versions and modifications of the AlphaVision software,
but it gives an good overview of what has to be done in principle for a full new version (not a
hot fix or patch, that will only require to replace single files).

ATTENTION:

The following procedure is only suitable for IMAC L system engineers or very advanced
IMAC L users (i.e. having very detailed knowledge of IMAC L engineering and functions). It is
strongly recommended to have such an update performed by your IMAC L support partner in
Siemens Marine Engineering, if this requirement should not be fulfilled!

Please observe the following basic instructions:

0 Before beginning your update, it is necessary to create a full backup of all your
working results (e.g. on a CD / DVD) ! This backup should include all files in the
C:\vision directory of the computer to be updated (use 7-Zip!) and all your Simatic S7
project files (use archive function of the Simatic Manager). Store this backup in a safe
space.

o Always update all PLCs and all PC’s (all OS’s + Engineering PC’s) of one IMAC L
project at the same time. Using a mix of old an new versions of AlphaVision within
one project is not allowed and will usually cause serious malfunction !

a Do a full ‘build’ procedure of all IMAC L software including all compilations and data
updates according to the ‘IMAC L Engineering Guideline’. Carefully watch out for any
warnings or failures being reported during this procedure. Investigate any unexpected
result.

o Do not try to perform this update procedure to a ships plant, if the ship is in operation
or even travelling. Make sure, that the IMAC L monitoring and control system is not
used and can be switched off for the required period of time.

a There shall be no error messages in the whole update procedure. Closely observe
every step and investigate every encountered error before you continue.

o Thoroughly test all basic functions after installing the new version (to make sure, that
things that worked before are still working after the update).

This instruction assumes, that you have left the project names & directories of the IMAC L
template project as they are. If you have either renamed projects / directories or have
created new ones of your own, you will have to adapt this instructions to cover your own
individual configuration.

This instruction will first show, how to update the IMAC L ‘Engineering PC’. In a second step
this description will then shown, how to strip this installation down to get an ‘OS’ installation.
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11.1 Installation of AlphaVision Software Packages

Use the following procedure to install the new AlphaVision software packages on your
Engineering PC:

- Close all IMAC L AlphaVision applications which are currently running (including all
IMAC L drivers and SoftPLC?7 instances).

- Rename the directory ‘C:\Vision’ (e.g. to C:\Vision_OId_yyyymmdd).

- Reboot your PC. This is necessary to unload DLL libraries from memory, that are
expected to be replaced by newer ones with the same name.
If you have a start command for AlphaVision in one of the ‘Autostart’ folders of your
PC, you will encounter errors from these commands. Ignore these error messages.

AlphaVision usually consists of five packages to be installed. The names of these packages
will vary from version to version, but the naming should make them identifiable. Use the
Windows Explorer to locate the required five packages in their new version:

Mame = | Grife
a7 An-10,04,01,00-Basis, exe 30,274 KB
a7 Ay-10,04,01,00-DC5, exe 1.339KB
a7 Aw-10.04,01.00-Goodies . exe 599 KB
137 Av-10,04.01.00-Siemens . exe 1.503 KB
037 Bw-10,04,01,00-50ftPLCT?  exe 20,252 KB

Install these five new AlphaVision software packages according to the following rules:

o Use the sequence of installation as shown in the screenshot above.
e Execute each of the packages by double-clicking on it in Windows Explorer.

e If prompted for the directory to which the package is to be installed, always
leave the default setting : ‘C:\vision’

e Use the installation option settings as shown in the next sections. Leave all
other settings in their default as suggested by the package installer.
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11.1.1 AlphaVision Package ,Basis’

Use the following installation options for AlphaVision Package ,Basis’:

& ALPHA-VISION 10.04.00.00 Packet Basis Setup

Chooze Components pr—n
Choose which Features of ALPHA-YTSIOMN 10.04,00.00 Packet Basis wou wank ko { 4:’
install, Tha

Check the components you want to install and uncheck the components you don't want to
install, Click Mext bo continue,

Select the type of install: !Custom e i
Cr, select the optional . Enginesring =
components you wish to m.[ :

install: G- [v] Runtime

- [¥] WIBL-KEY Runtime
Microsoft Wisual CfC++ Runtime

Space required; 79,.5MB

< Back ]l Mext = | [ Cancel

11.1.2 AlphaVision Package ,DCS’
Use the following installation options for AlphaVision Package ,DCS’:

© ALPHA-VISION 10.04.00.00 Packet DCS Setup

Choose Components ey
Choose which Features of ALPHA-YISION 10,04.00,00 Packet DCS you want to install, { "}

Check the components vou want to install and uncheck the components vou don't want to
install, Click Mext bo continue,

Select components to install: m

Space required: 2,9ME

< Back “ MNexk = ] [ Cancel

11.1.3 AlphaVision Package ,Goodies’

The package ‘Goodies’ has no installation options:
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1114 AlphaVision Package ,Siemens’

Use the following installation options for AlphaVision Package

,Siemens’;

Chooze Components pr—n
Choose which Features of ALPHA-YTSION 10.04,00.00 Packet Siemens you want to {4}
install, Tha

Check the components you want to install and uncheck the components you don't want to
install, Click Mext bo continue,

Select the bype of install;

Or, select the optional & [] siemens
campaonents yau wish ta
install:

Space required; 2,8MB

« Back “ Mext = ] [ Cancel

11.1.5 AlphaVision Package ,SoftPLC7’
Use the following installation options for AlphaVision Package

Check the components vou want to install and uncheck the components vou don't want to
install, Click Mext bo continue,

Select the type of install;

Cr, select the optional ®- [+] 5oftPLCT
Components you wish to [ WIBL-KEY Runtime
install:

[ Micrasoft visual CfC++ Runtime

Space required: 14,.8ME

, SOftPLC7’:

# ALPHA-VISION 10.04.00.00 Packet SoftPLC7 Setup =3
Choose Components e
Choose which Features of ALPHA-YISION 10.04,00,00 Packet SoftPLC7 wou want ta {J}
install, iy

[ < Back “ MNexk = ] [ Cancel

l

Remark: Duplicate installation of options ‘WibuKey Runtim
Runtime’ is not required (although it would do no

e’ and ‘Microsoft Visual C/C++
damage). These options were

already installed with the ‘Basis’ package. Deselect them here.
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11.2 Create AlphaVision ‘PMU‘ Project for IMAC L

In order to copy the AlphaVision ‘PMU’ Project from the prior version of AlphaVision, it is first
necessary to create an empty project with the required name, using the PMU project
administration tool. This ‘empty’ project can then later be replaced by the required (existing)
IMAC L project. This procedure is required in order to make the sample project ‘known’ to the
PMU database.

- Double-Click on the ‘PMU’ Icon on the desktop. PMU will open with the default
sample project ‘DEMO’ as the single project available. Click ‘Cancel’ in order to not
open the ‘DEMO’ project (if you should want to ‘investigate’ the DEMO project, you
may enter the password, which is ‘DEMO’)

£.% ALPHA-YISION = 1of x1
Project Version Start Help
Projects: Yersions:
x
Enter passwaord for projectTUT
Il [10 signs]
sl

Aol |BEET sloixd|EEETET sloix

- Clickon ‘Project > New’
- Enter the Project Name, Description and Directory precisely as shown below
(including the ‘underscores’) :

x
Project name: I|M-"-'«C_L
Description: ||M.-’-‘«C_L
Fitecti: [CWISIONYPRIAMAC_L
Comment; IMAC L Template Project =]
b
1 F
Source: II:: WASIOMNAPRISTLT Y

Ok I Cancel I

- (The PMU will show a new project IMAC_L’ in it's projects window.
- Click on this new Project ‘IMAC_L’
- The program will ask for a password. Enter IMAC_L’ and click on ‘OK’:
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TR 1;

Enter pazzword for projectiMAC_L

- Enter the Version Name and Description precisely as shown below :

B {110 signs)
Ok I Cancel |
- Click on ‘Version > New’
New version NN x|
Wersion nanme:; |1 .0g
Descriphian: |‘|_UD
Comment: ;I
A >|
Bravse.. I I 1 EDD}llathﬁ
Source; |I3:WISIDN'\PHJ'\TUT\M:’-‘«STEH\.
Ok I Cancel I

- The PMU will display the new Project IMAC_L’ with its version ‘1.00’
- Close the PMU window

=0l
Versions:
“N1.00 1.00
TUT TUT
Ao x| Ao x| (0] |
a0l x| 2l x| EE a0l x|

- Open the Windows Explorer and delete the directory ‘C:\Vision\prl\lMAC L’ , its sub-
folder “1.00’ and all files contained in these two directories.

- The following installation of the already existing IMAC L project files from the project
to be updated will replace the now empty project directory with a valid project, that
can be opened and edited by the PMU program.
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11.3 Copy files from existing IMAC L Project

As this section describes, how to update an existing IMAC L project to a newer version, it is
now time to copy the project specific files & folders from the existing (old version) of the
IMAC L project to the newly created ‘C:\vision’. directory.

Please Copy the following files & folders from your old project (which should be named
‘C:\Vision\Old_yyymmdd’ according to this description) back to the new °‘C:\vision’
directory :

o Directory \prjAvET (with all files and subfolders)
a Directory \pri\IMAC_L (with all files and subfolders)
o Directory \SoftPIc7Data  (with all files and subfolders)
a Directory \Win_EAS\ (with all files and subfolders)
o File \bin\IMAC _L.cfg

a File \bin\vision.ini

a File \bin\VISION.LIC

a File \bin\VISION_SIC.INI

o File \bin\Vision2000.ini

This procedure should have copied all required files and folders for your IMAC L project (if
you stored them in the location as suggested by the ‘IMAC L Engineering Guideline’). Just to
be careful, please check your old project directory for any project specific files or folders
which were not covered by the copy procedure as depicted above. Copy such files / folders
manually as required for your project.
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11.4 Create an ‘OS’ Project from ‘Engineering PC’

The ‘OS’ version of IMAC L is a stripped down version of the Installation of the Engineering
PC (as described above). To update an ‘OS’ version of AlphaVision, please proceed as
follows:

- Compete the update procedure for your Engineering PC (as described above in this
section) and make sure that your project it is working (compiling) properly on it.

- On the OS to be updated close all IMAC L AlphaVision applications which are
currently running (including all IMAC L drivers and SoftPLC7 instances).

- On the OS to be updated rename the existing IMAC L project directory ‘C:\Vision’
(e.g. to ‘C:\Vision_0OS_OIld_yyyymmdd’).

- Reboot the OS PC to be updated. This is necessary to unload DLL libraries from
memory. If you have a start command for AlphaVision in the ‘Autostart’ folder of your
OS, you will encounter errors from these commands during booting. Ignore these
error messages.

- copy the whole ‘C:\vision\’ from your Engineering PC to your OS.

- Delete the following files & folders from the OS’s ‘C:\vision\’ directory:

a Directory \prfAvVET\IMAC _L\ (with all files and subfolders)
o Directory \prj\ (with all files and subfolders)
o Directory \Win_EAS\ (with all files and subfolders)

- Copy the following files and folders from your old OS project (which should be
named ‘C:\Vision_OS_Old_yyyymmdd’ according to this description) back to the
new ‘C:\vision’ directory of the OS :

a File \bin\IMAC_L.cfg

a File \bin\vision.ini

a File \bin\VISION.LIC

a File \bin\VISION_SIC.INI
a File \bin\Vision2000.ini
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11.5 Updating the AbvSPU Signal Processing Unit

In most cases new versions of AlphaVision require the installation of a new AbvSPU Signal
processing unit for the IMAC L PCUs as well. If your new AlphaVision version contains such
a new Version of the AbvSpu you will have to install this for every PCU of your project.

After the installation of the AlphaVision packages, the files required for an AbvSPU update
are located in a Zip file that can be found in the ‘C:\vision\extinst\' directory.

A new version of the AbvSPU is delivered as two files in this Zip file, which are named:
o ‘SpuOpt Udp_ 1.AWL’ (Simatic source file)

a ‘ABVSPU.SDF (System Data File)

There are some other files in this ZIP file, which are not required for IMAC L. Unpack these
two files to a local directory of your choice to have them ready for the next step.

11.5.1 Compiling the AbvSPU Signal Processing Unit

You will first have to compile these AbvSPU before copying it to your PCUs. IMAC L contains
a special project file, which was set up to hold and compile a new Version of the AbvSPU.
This IMAC L project for compiling the AbvSPU is located on your ‘IMAC L Engineering
System Install CD’:

AIMAC_L_S7_Project\S7_AbvSPU_Compile.zip’

To unpack this IMAC L ‘AbvSPU_Compile’-project please proceed in the same way as
described in Section =9 'Unpacking the IMAC L Simatic S7 Project’ on page 58). The only
difference here is, that you point to the ‘S7_AbvSPU_Compile.zip’ archive file from your
‘IMAC L Engineering System Install CD’.

If you have retrieved this special project in your Simatic Manager, please use the following
procedure:

Retrieve the required AbvSPU Symbols:

- Open the S7_AbvSPU Simatic Project

- In Simatic Manager click on the ‘S7_AbvSPU -> CPU > S7 Program’ folder

- Double-Click on the ‘Symbole’ or ‘Symbols’ icon. The Symbol Editor will open.

- Mark all Symbols in this list and delete them all.

- Save the Symbols List

- Click on ‘Symbol Table > Import’

- In the dialogue window select ‘Files of Type’ as ‘System Data Format (*.SDF)'.

- Point to the file ‘ABVSPU.SDF’ (see above).

- Click on Open

- Confirm in the next dialogue with ‘YES’ to continue. A dialogue will indicate, that no
errors occurred (warnings can be ignored).

- In the Symbol Editor click on ‘Symbol Table > Save’

- Close the Symbol Editor
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Retrieve & Compile AbvSPU:

Click on the ‘S7_AbvSPU > CPU > S7 Program -> Sources’ folder

In the right window : Right-click 2 Insert new Object > External Source

In the dialogue box point to the new ‘SpuOpt_Udp_1.AWL’ file

Click on Open

Answer ‘Yes’ to the ‘Overwrite ?’ dialogue

(the Source File will be opened automatically)

Click on File > Compile

The source file will be compiled. No errors will occur, but lots of warnings are to be
expected (> 900). This is normal and can be ignored.

Modify AbvSPU for IMAC L:

Click on the ‘S7_AbvSPU > CPU -> S7 Program > Blocks’ folder

Double-Click on block DB190 (‘abvspu_DB_UDP’)

Edit the following cells to contain the correct values for IMAC L.:
= DB190.DBW34 = W#16#1FEC (HW-address from CP343 HW-config)
= DB190.DBW36 = W#16#1FED

In the DB-Editor click on View -> Data View

In the DB-Editor click on Edit -> Initialize Data Block.

Click “Yes’ in Dialogue.

In the DB-Editor click on File -> Save

Close the DB

If these steps were successful, the compiling of the new AbvSPU was successful.

11.5.2

Distributing the AbvSPU Signal Processing Unit to PCUs

The last step in the update of the AbvSpu Update is to copy the resulting files to all PCUs of
the IMAC L project to be updated. Most (but not all) of the files in the ‘PCUx->S7 Program
- Blocks’ are to be copied. To select the right files, proceed as follows:

Select & Copy AbvSPU blocks:

Click on the ‘PCUx->S7 Program -> Blocks’ folder

Click twice on the text caption of the ‘Last Modified’ column. The blocks will now be
sorted according to the ‘last modified’ date (newest on top).

Select all files, which were created during the compiling in the previous step.

From the selected files, unselect ‘OB1’, ‘OB100" and ‘OB101’ (hold down ‘Ctrl’ and
click on them’. Now you have selected the required files, which are to be copied to
each PCU of your project.

Click on Edit > Copy

Paste AbvSPU blocks to all PCUs:

Open your IMAC L S7 project with the Simatic Manager

Click on the IMAC_L_xxx - PCU1 > CPU - S7 Program -> Bausteine’ folder
Click on Edit > Paste

You are promted, if you want to replace existing blocks. Answer: YES to All !

Repeat this last step for all PCUs in your project.

Don’'t forget the AbvSPU instance, which is contained in the ‘OS 99 project for
Station in Control (SIC). See IMAC L Engineering Guideline, section ‘ReCompile the
SoftPLC Program for ‘OS 99”
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11.6 Compiling & Building the IMAC L Project

Now everything is in place to completely build your IMAC L project according to the
procedures as described in the ‘IMAC L Engineering Guideline’:

- Compile and build your complete project once again (beginning from the Excel file).
Do not omit any possible step (carefully watch for error messages or warnings)

- Distribute the new DIS / DO files to all OSs.

- Stop all PLCs.

- Erase ***completely*** and then reload each PCU (do not transmit only the modified
blocks).

- Startall PLCs.

- Startall OSs

11.7 Special Hints for Updates

o If you had an old version of AlphaVison and you experienced problems with time
setting or time synchronization between stations, you should after upgrading to a new
Alpha-Vision upgrade the old project to use the new TimeMaster function of IMAC L.
The IMAC L ‘Engineering Guideline’ document contains a very detailed description on
this new function and the necessary upgrade steps from older versions (before
February 2006).

o New AlphaVision versions may have changed settings (e.g. default directory names
in the PrjAvET directory for Excel importing did chang frequently in the past).
Carefully watch for such changes and react appropriately.

o If you are an IMAC L system engineer working on a new release for IMAC L, please
carefully check, if adjustments in the IMAC L documentation are required. Users will
otherwise not know how to handle things. This might fill your eMail inbox a little ;-)
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